FAT is corrupted, MAC OS user

When I try to turn on my Sansa Clip 1GB it gives me the message: “FAT is corrupted. Connect device to PC and recover FAT.” I tried connecting it to my iMac as usual, and now, the computer doesn’t recognize the Sansa Clip, in that it doesn’t show up on the desktop. When I look at the Mac system info however, the device is listed as connected via USB, as it should be. 

I also tried connecting the Sansa Clip directly to the computer (rather than through the USB hub) and it still doesn’t show up on the desktop.

After reading some posts on this forum, I also tried forcing MSC mode (I think that’s what it’s called) by pressing the center while attaching the device to the computer while the device is locked. That didn’t work either.

Is there anything else I can do?



Message Edited by dkossy on 01-23-2010 10:32 PM

Message Edited by dkossy on 01-23-2010 10:33 PM

Not sure how things work on a mac. See if you can get hold of a PC, make sure device is in MSC mode. If PC recognizes you should be able to format. Try fat32 first, if that doesn’t work try fat16. My 1gb M240 worked either way.

After reading some other posts about using a Mac with the Sansa Clip, I solved the problem by using the Mac Disk Utility program to erase (reformat) the device. After that, the Sansa Clip appeared on my desktop and seems to be working fine again.

I think the reason the FAT became corrupted was that I had tried to remove some files from the Sansa Clip while it was connected to the Mac, using the Finder. That’s when it started malfunctioning. Now, I will only remove files manually, when it’s not connected.

How long did it take to do the erase via Disk Utility?  I have tried and tried but it seems to just hang. I’ve left it for spin for hours. I’m going to have to resort to handing it over to my son to take to a friends house for a fix via a Windows computer – ack!  I’ve tried it under my User name as well as my Admin User.

By the way – I have been using Sansa Clips with my Mac for a couple of years now and this is the first time I have had any problems with the filing system.  I have always used the Mac Finder to add, remove, and move Files from place to place on the Clip. 

I know exactly what I did this time though – I dragged files from the clip to my Trash, emptied it, added more files to the Sansa, then I went to the Log In screen to put it to Sleep until the next family member needed it, remembered the Clip and instead of logging back in I disconnected the Clip. Wrong thing to do!!  The Fat became corrupted (FAT stands for File Allocation Table i.e – where does everything go and how does the clip find it.)

I use iTunes Get Info to change the File Tags to Audio Book since I listen mainly to Conference Presentations, and Sermon Audio.com mp3s - rarely ever music.  Using this, I can listen to mp3s via the Clips Audio Book, Podcast, as well as its Music options rather than just making New Folders to merely keep the Finder’s view of the Clip files organized.

You can treat the Clip like any other mounted device as far as moving files, etc.   The only thing is you must empty the Trash for it to update removed files from the Clip.  And you must Eject the Clip and wait for the display to not say ‘Disconnecting’ or 'Updating" before removing the usb plug.

Hope this helps other Mac users.

Before reformatting with Disk Utility , you can try its Repair Disk option. If you do that, check the Show details box and repeat doing Repair Disk until you get the same result twice in a row.

Well, using Disk Utility doesn’t work.  I have tried it repeatedly over the last few weeks and the barber pole just turns and turns.  I have left it for hours at a time, nothing changes sometimes it even locks up the iMac.

Just on the off chance one of you may see a clue in the following:

The Results of “VERIFY DISK” no matter which of the lines for the Clip in the lefthand box is selected:

Verifying volume “SanDisk Sansa Clip 1GB Media”
fat16_get: invalid cluster (0)
** /dev/disk2
FAT size too small, 60784 entries won’t fit into 0 sectors
Fix total sectors? no
Continuing, assuming 4294967294 clusters
** Phase 1 - Preparing FAT
Error: This disk needs to be repaired. Click Repair Disk.

1st line  = (normal font) “995.59 MB SanDisk Sansa Clip 1GB Media” the following appears below the result field:

Disk Description :    SanDisk Sansa Clip 1GB Media    Total Capacity :    995.9 MB (995,885,056 Bytes)
     Connection Bus :    USB    Write Status :    Read/Write
     Connection Type :    External    S.M.A.R.T. Status :    Not Supported
     USB Serial Number :    3E1AF9143207B6A80000000000000000    Partition Map Scheme :    Unformatted

2nd line = (greyed out font) “SanDisk Sansa Clip 1GB Media” the following appears below the result field:

 Mount Point :    Not mounted    Capacity :    995.9 MB (995,885,056 Bytes)
     Format :    MS-DOS (FAT32)    Available :    -
     Owners Enabled :    -    Used :    -
     Number of Folders :    -    Number of Files :    -

I’m having the same issues. Have you resolved the problem with your sansaclip 1gb?

I have been having the same problem with my Clip+. I plug it into the Mac Pro and it is not recognized in the Finder or ITunes. So I opened the Disc Utility and followed the directions (which I also did yesterday on my other clip+ and it now works fine). Did all the steps outlined but now the “Unmounting DisK” twirly bar has been running for 30 minutes. How long should this take? Do I just unplug it?