fast forward problem on large files

Hi,

I have a Sansa m250 (firmware v. 4.1.08A). I download audiobooks from the library (Overdrive Media Console files) that are divided in parts and mediamarkers. Each part might include 9 chapters and the mediamarkers divide the parts in individual chapters. It all works well in the Overdrive media console but when I play the book on my player, it doesn’t recognize the mediamarkers and I can only move forward between parts; that is 9 or 10 chapters at a time.

I read in a forum for the Sansa clip that downloading the latest firmware might fix this problems but I just upgraded my firmware to the latest available and is still not working.

Any help or suggestions will be appreciated. Thanks!

Hey,

I am having the exact same issue. I purchased this little player from Amazon ($30) because I am not able to play the files from Overdrive on my iPod. I am also listening to audiobooks and when I get to around 22:00 of fast-forwarding and let go, it automatically skips to the next file–eventhough I am not even half-way past the length of this track. It is really frustrating!

-Kyle 

Same problem…plus I am finding the m250 doesn’t hold my place on shutdown. Will someone please help?

Linda

Well, I contacted support on the issue and their exact words were:

“Please be informed that resume playback and the fast forward options of the player is good only for an ordinary song, it may or may not work properly on the audiobook file depending on the capability of the book”

Then when I replied with all the suggestions they mentioned as failed, they responded with the following:

“Please try to use ordinary song and check if it will do the resume playback and fast forward properly. The resume playback and the fas formward feature of the player will depend on the kind of file or song that you are playing. If still the same thing please return it to Amazon.com for replacement. You haev a 1-month return policy for the product.”

Pretty much tough luck.

Thanks Kyle…if I return it to Amazon, it won’t be for a replacement of same model…or possibly same brand. Very disappointing after such good results with M240…thanks again for getting some answers for us.

Linda

@lindas wrote:

… I am finding the m250 doesn’t hold my place on shutdown.

I am going to experiment with pressing the Pause button before shutting down on a longer, spoken word track. By longer I mean 15 minutes or more. I have had some success with this on a podcast track of about 30 minutes that I downloaded. Even though the m250 could not successfully fast forward through the track or remember where it left off when I shutdown, pressing Pause before shutdown allowed me to pick up where I left off. That will now become my habit for all tracks: Pause first, then shutdown. We’ll see.

Actually I even tried the pause thing as well and it works fine for a playhead position of less than 18 minutes or so. After that, when it goes to sleep and you wake it back up, the playhead will still be in the correct spot, but the track will actually begin playing the beginning of the song.

As the saying goes, you get what you pay for.

Well, how annoying.  My little m230 (512MB) never had any of these problems. :frowning:

@kylehayes wrote:

Actually I even tried the pause thing as well and it works fine for a playhead position of less than 18 minutes or so.

Hmmm.  Did the engineers take a brain-dead shortcut?  60 secs times 18 minutes is 1080 seconds.  Did someone somewhere along the way build in a stupid limit of 1,000 seconds for pause/restart to work properly?  We’ll never know, will we?

Sansa programmers:  This is a really big problem, and I registered just to add my voice to the thread.  I bought an m250 primarily for podcasts, and this bug makes the device essentially useless if I have to power down after the 45-ish minute mark.  The device loses my place, and I can’t fast forward to where I stopped, since it skips back to the beginning of the track.  The ONLY way to resume my listening is to let the device play through at normal speed until I get to my stopping point.  Please, please, PLEASE fix this problem! 

I know this is not the top of your Sansa line by any means, but I thought it was a great value.  I kept bragging to my wife how my m250 was more fully featured than her 4x more expensive ipod shuffle.  However, until this problem is fixed, my Sansa isn’t even worth continuing to use.  Please help!

catapult37, I don’t know much trouble you are willing to go to, but there is audio editing software available to cut your podcasts down to multiple, smaller tracks.

Audacity is free. I use MP3 Magic ($9.95) to slice longer files into shorter segments.

Thanks for your reply, but that is more trouble than should be necessary for this basic feature to work.  Looks like I’ll be tossing the m250 practically as soon as I bought it.  Here I thought I’d made such a great, economical purchase…

Yeah, I understand. What a colossal mistake on Sandisk’s part. I was thoroughly delighted with my little m230 but it eventually died. So, I bought the m250 without even considering the competition, thinking I would get the same great performance. Alas, no. And now the competitors have an open window of opportunity.

@catapult37 wrote:

Sansa programmers:  This is a really big problem, and I registered just to add my voice to the thread…However, until this problem is fixed, my Sansa isn’t even worth continuing to use.  Please help!

Fully agree. Great value, but, not so much when it doesn’t work

Agree, this should be fixed.  Resume and fast-forward work fine on my two M230s and one M240.  The customers pay the price for some rookie programmer’s mistakes?  Make him/her work unpaid overtime and fix it, for all the customer ill will s/he caused Sandisk.

Same complaint here. I had an older model that worked just fine for Overdrive audiobooks. It was recommended to me by a friend who also listens to audio books. I used it for over a year. I recently lost my player and automatically replaced it by buying the latest model. But can’t listen straight through to an hour+ long segment, I lose my place in the book and can’t even fast forward to find the lost place. Ugh! Really sad when an older model functions better than the new one! If you can fix this, you’ll keep some loyal customers!

I have an m230, use it for podcast listening, and have the same problem.  I speculated that it was caused by poor encoding to MP3, or errors in the MP3 file, so I tried transcoding to WMA, and low and behold, no more skipping when fast forwarding.  I haven’t tested whether it saves my place upon power-down, I’ll try that tonight when I get home.

So I use the free Microsoft “Windows Media Encoding Script” command line encoder to transcode my podcasts.  I use Juice to download the files, and have it (Juice) invoke a VBS script that transcodes and copies the WMA’s to my Sansa (which I leave hooked up as a removable drive at night).

If you don’t use Windows, maybe you could try encoding to a different audio format to see if that also works.

Interesting getaround you’ve found, wooderson.  Strange that WMA solves the problem, since OverDrive Media audiobooks are DRM’d WMA.  Let us know whether it resumes properly, and whether long podcasts over 22 minutes don’t skip on fast forwarding.

my findings and solutions in this thread…

http://forums.sandisk.com/sansa/board/message?board.id=m200&message.id=1897#M1897

Message Edited by jjrphs on 10-31-2008 03:54 AM

On the face of these last posts that present solutions, I’m confused.

People report the problem on

  • OverDrive Media audiobooks (DRM’d WMA),

  • MP3 podcasts (catapult37 on the bottom of the first page and wooderson on the second page),

  • ripped WMA audiobooks (jjrphs).

Solutions are reported represumably in the context of those individuals’ problem files:

  • MP3 podcasts: wooderson says to convert to WMA.

  • ripped WMA audiobooks: jjrphs says to convert to MP3.

  • DRM’d WMA audiobooks: [no solution] 

Is this too simplistic a summary?  Am I missing something? 

One person’s plain WMA (ripped) doesn’t work, yet another person’s solution is to convert to plain WMA?  Seems that it might be the WMA settings, like CBR vs. VBR, or bitrate. 

Same with MP3.  For one it’s a problem, for another it’s a solution.  Can either or both of you tell us your encoder settings that worked (and optionallly, if you remember, the settings that didn’t work)?  We may narrow down to a universal solution (to solve for OverDrive audiobooks, we’ll have to purchase a converter program so we can get to some encoding of plain WMA or MP3).  This will be great to get back usage of our m200s.