Extremely slow

I too have experienced slow transfer rates (40 Megabytes per second) on USB 3.1 ports on a recently bought a 1TB SanDisk Extreme Portable SSD. I noticed that I was having slow transfer rates on all of the USB-C to USB-A cables I was using. I was however getting full speed on the supplied far-too-short cable.

I created an account here and posted this reply in case anyone else experiences the same problem as I have a solution. The problem is not with the SSD but with your cables!

After some research, I found that the majority of USB-C to USB-A cables are rated at USB 2.0 speeds which have a max transfer of 480 megabits per second or 48 Megabytes per second. Hence, the reason why we are only getting around 40 Megabytes per second transfer speeds!).

You need to ensure that your cables are USB-C to USB-A 3.0 which is also called 3.1 Gen 1. A USB-C to USB-C cable will also work as long as it too is 3.0 or 3.1 Gen 1 compliant.

USB 3.0 (also called USB 3.1 Gen 1) supports transfer speeds of up to 5 gigabits per second or 500 Megabytes per second.

You will need to buy ‘faster’ cables which can support 5gbps transfer rates. Carefully read the specifications. I am in the UK and bought some Anker and Amazon Basic cables sold through Amazon UK.

Search Amazon for either “ANKER POWERLINE+ USB C TO USB 3.0 CABLE” or “AMAZONBASICS USB TYPE-C TO TYPE-A 3.1 GEN 1 CABLE” and purchase those.  

I hope this helps! Take care!

I am trying to figure this out - using the 2 TB for media Managment on a broadcast shoot —. Friday the 2tb started slow and was going to take over 50 minutes to transfer 128gb on a fast MacBook Pro . I rebooted a few times and got it to transfer in 7 minutes . This morning I had the same issue and finally went to a standard g drive and they are transferring at the expected 18 mts -

Ps - I am using the supplied cables - to the usb 3 ports -

Extreme Pro Portable SSD.

I also have issues using the USB-A 3.1 to USB-c on my Dell Notebook (XPS 7590).

Using usb-c I get expected speed and using the same cable on USB-A 3.1 port on my desktop I also receive expected speed.  Using the supplied cables.


I think it is the provided cable.  I swapped cables and now receive much better performance.

Order a usb-c to a usb-A 3.1 gen 2 cable from Amazon and will test again.


Performance with different USB-c to USB-A cable.  I am thinking this is only a USB 3.0 cable…so performance is not max.


I also have incredibly slow performance. Way worse than anything I’ve seen in this thread so far. I am using the drive to store many programming projects so that they are easy to transport back and forth between home and work. Dealing with MANY small files. Formatted as NTFS thinking that would help and nada. 

Im getting anywhere from 200kb (YES KB) to 2mb / sec. Its up and down left and right. Running it on a brand new lenovo laptop with usb-c ports - plugged directly into the usb-c ports. 

I dont know if its faulty or what - but it formats and takes the data, its just incredibly slow. I almost wish I had just grabbed a 256gb USB3 Flashdisk at this point - they are much faster than this thing.

Media Giant Design

Website Design and Marketing

Try full format

  1. Right click the drive you want to format
  2. Click FORMAT
  4. Reformat the drive (Very slow too)

There! it should work as new

got the same issue and it’s sometimes automatically fixed. how is that possible iosemus

I also went through the same situation, in fact the problem is with the cable.
Try don`t the bend the cable!

Try and reverse the included cable. I was also only getting 40 something mbps. Reversed the cable and boom. My 2015 13” MacBook Pro is getting 450~ish mbps.


Not Necessary just reverse the supplied cable and that should solve the speed issue. It did for me.

1 Like

Guys! :joy::joy:
There’s nothing wrong with the included Type-C to Type-A adapter, y’all just using it wrong. I did it myself. The adapter is meant to lock into the USB-C cable and has ridges that connect perfectly. If you just insert the USB-C cable in the opposite direction, the ridges don’t sit into each other and a proper connection isn’t formed. I got 48 MBps from my drive after it arrived this morning and I was shocked to say the least. An hour later I tried again and without realising, I inserted the cable into the adapter in the right way and voila, ez 430 MBps.

You do not need any extra cables! The one supplied along with the C to A adapter is already as fast as it can get!

Thanks so much for the advice.
Who would’ve guessed that a simple switch of directions would do the trick.
My external SSD didn’t work anywhere near as fast as it should’ve.

I’m thinking about upgrading my SSD though because I need more space and looked through the following article for everything I have to consider:

It’s a German website but you can just translate it via Google Translate. Is there anything else I have to keep in mind that hasn’t been mentioned in the article?

Thanks in advance

I have the same problem : around 40mb/s using the usb c to usb c cable from seagate and more than 400 using the adapter, I think that the problem come from my usb c port on my laptop.
I have an Acer Aspire VX5 - 591G with a USB 3.1 gen 1 (up to 5 Gbit/s, 5 V , 3A of charging), I’ve asked Acer support and they told me to reinstall windows :smile:, will try when I’ll have some times.

I had the same problem on a brand new Extreme Portable SSD. Reading the posts here, tried switching the direction and a 9 hour transfer is now a 30 minute transfer.

I knew about directional cables for Hi-Fi equipment and its effect on sound quality but didn’t realise it can affect data speed transmission (though I’m guessing for different reasons).

I don’t want to disturb the cable mid job but I couldn’t see any obvious indication of correct direction of travel; there isn’t anything on the packaging either.

Is this normal for data cables? I imagine I don’t need to reverse the direction if I wanted to copy back again…lol!

You can see from the photo where I reversed the direction. Fortunately didn’t have to cancel the job, I just paused it and it worked!


I was looking for a solution a long time. 36 MB/s read/write was crazy low. IT WAS THE CABLE!
My expensive cables were not good enough. If you use the provided cable, read the comment of user mri9ank above.It is THE solution!

Sir i am also facing same issue

hi, guys.
i ve just bought a external ssd sandisk 1TB and it performs ridiculously slow, sending or receiving files at 42mbps max. there is just this page on google that is talking about this issue, and i still have no resolution for this problem. i ve tried 4 different cables, all type c to usb 3.0, on many usb ports, and the speed rate keeps the same.
does anyone have a suggestion for all this?

I know this is a super old thread, but I actually did a small video about this to demonstrate the issue. The short summary of the fix is: Just turn the cable upside down and that’ll likely fix the speed issue, if you’re converting the USB-C adapter in any way.


@kimimeil You have placed an irrelevant link here. I am wondering what is its purpose here?