Error installing Sandisk SSD Dashboard

Hi, im having this error everytime I try to install SSD Dashboard, can anyone help me fix this?

Screenshot_1.png

Same exact issue and nothing on Sandisk knowledge base.

hey, i’ve fixed it. download and install internet explorer 9 or higher version and problem solved :slight_smile:

In an advisory, Western Digital confirmed the issues and urged customers to install the latest version of the company’s SanDisk SSD Dashboard and Western Digital SSD Dashboard UPSers

I having the exact same issue trying to upgrade from v2.3.3.0 to the latest version, I can’t un-install either by add/remove program or running the old installer, each method gives the same result you have shown in your screenshot, I am running W10 build 1903.

I guess we have to wait for a new build of the DashBoard to fix this issue :frowning:

 I’m having the same problem. Went so far as to remove all files in all user accounts associated with Sandisk, edited registry to remove all keys associated with Sandisk and also removed WDdashboard files and keys. Downloded new installer and same result.

Failed to download

object not found (0x80090011): Lista_update.xml

I remember the last update from sandisk had problems to but can’t remember what I did to solve it back then.

Hope they fix it soon.

It’s a security issue.  I’ve been able to resolve this by running the Setup program as either TrustedInstaller or System account.  (Tried both approaches in 2 different systems and both worked.)

To run the Setup program as TrustedInstaller I used a tool ExecTI by Winaero.  (There are other tools that do this.)

To run the Setup program as System I used psexec from Sysinternals…

psexec -i -s <full path to Setup>

or alternatively rum

psexec -i -s cmd

or

psexec -i -s explorer

then search for the Setup program and run it.

1 Like

Same here.

I’ve tried to install latest IE like @lorenxd (IE9 and IE11 later on) but it didnt work.

Also tried what @travisck said and it didnt work either.

Pls. Any help?

I tried the Psexec cmd in powershell and then ran the installer from the popup CMD promt in system32 where I placed the psexec file. It worked fine like a charm. Thanks Travisk for the help!

Same error here. tried to install as Administrator (win 10) - no success

Please repair this !!

using psexc64 installed the exe correctly. But shame on SanDisk for putting such an faulty installer on the market :frowning:

1 Like

January 15th and the installer still doesn’t work with Win7. All antivirus inactive. Should be straight forward.

Perhaps the company cannot afford a capable programmer for the task?

Was just going to purchase a 6th Sandisk SSD, but after two failures out of five, and now this, I am a bit reticent.

Sandisk, do you think it’s wise to leave these issues unresolved for so long? Having been a programmer for several decades … this is not rocket science. Am I right?

Forcing the customer to use a specific browser is something from Windows 98 days.

One would expect an installation tool to be standalone by now.

I do not use IE anything, as many won’t, yet we had to install IE11 to get the SanDisk installer to work.

The fun part was finding that there was no firmware update for my disks after wasting my time looking for a solution.

If you can read our comments about your outdated tool(s), perhaps you can justify updating your installation techniques to be more generic, and not browser dependent.

Thanks …

This worked for me running Windows 7:

Download SanDisk dashboard v1.4.4 from here: https://download.cnet.com/SanDisk-SSD-Dashboard/3000-18512_4-77533150.html#full-specs

Then sadly you have to install IE11 from Microsoft website. After you restart, it will finish. Then install SanDisk Dash v1.4.4

After it finishes installing and you run it and it works, then you can download the v2.6.0.0 from SanDisk website and it will uninstall v.1.4.4 and then install the v2.6.0.0.

It takes few minutes to install the new version, so be patient. It worked for me and few other laptops.

I got version 2.6.0.0 working by just uninstalling v2.5.1.0.:

  1. Previously tried to update to 2.6 from the Dashboard and got the error message

  2. Uninstalled v2.5.1.0 and was immediately offered to install v2.6.0 in the uninstaller final message box

  3. Allowed v.2.6.0 to install from the uninstaller

  4. Happiness

I did use Ashampoo Uninstaller but I assume it will work with normal Windows uninstaller because all I did was run the program’s own installer .exe

Hallo

While trying to install the newest version of dashboard in a Windows 7 system I keep getting the error message below, almost immediately after running the setup file.

I’ve installed version 1.4.4.4 and the same error appears when trying to update from within it. Also running through psexec results in the same error

To be honest I am quite disappointed - previously used Samsung SSD and their disk management software runs without issues

Untitled-1.jpg