Empty Playlists, missing Podcasts, relative path names

After running across many posts touching on but not fully covering the issue of the Sansa Clip Plus creating empty Playlists and not allowing Podcast files to be in Playlists I thought I’d start a post hopefully covering the issues in full so others don’t have to piece things together on their own.

The Clip Plus will view files with the “Genre” tag set to “Podcast” (or varients such as “Podcasts”, “Podcasting” etc) strictly as Podcast files and not eligible for use in Playlists.  If you create a Playlist and it appears Empty in your Sansa Clip or missing entries for files you know are in your Playlist, change the “Genre” field for those files to something besides “Podcast”.

If your Playlists still appear empty on your Sansa Clip, make sure the Playlist uses relative path names.  The Sansa Clip uses a different top-level directory that is hidden from your computer.  That means that although your computer sees that it is putting your files in the “Music” directory linked off of the root directory on the Sansa Clip, there is actually a directory level above that.  Most syncing programs seem to use absolute path names vs relative (starting with the slash symbol, meaning the path it is giving starts from the root directory.)  Since the computer does not know the true root directory of the Sansa Clip it is unable to create proper path names for the playlist it creates on the Sansa Clip.  They need to use relative path names (using “…\Music” to indicate the main “Music” directory on the Sansa Clip when the Playlist is in the “Playlists” directory, the “…” meaning go up one directory from the current directory (in this case one level up from “Playlists”) then back down to the “Music” directory.

There are couple of ways to fix the Playlists to use relative instead of absolute paths when your Sansa Clip is set to use MSC mode (Settings\System Settings\USB Mode\MSC):

  1.  Let your syncing software create a playlist with absolute path names:

 After the playlist is created on the Sansa Plus, navigate to the Sansa Clip\Playlists directory.

  Open the new Playlist file with a text editor (such as Notepad on a Windows machine)

  Use Edit/Replace to replace every instance of “\Music” with “…\Music”

  Save the updated playlist file.

  1.  Set your syncing software to use Relative Paths instead of Absolute Paths:

  This is software dependant, and not all programs will let you do this. MediaMonkey is a VERY good, free program, and starting with Version 4.0 will allow this (version 4 is currently in Beta.)

 You can get MediaMonkey at:

http://www.mediamonkey.com/

And you can get the latest Beta at:

http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=54426

Be sure to jump to the most recent post in the thread to get the most current Regular Beta.

To set MediaMonkey 4 to use relative paths, go to:Tools/Options/Portable/Audio Devices

Select the “d_USBMass1.dll” Plug-In File and click the “Configure” button.

Under the “Options” tab, select “Device configuration”

Put a name in the “Device Name” field (such as "Sansa Clip+)

Select the “Drive Letter” your computer currently has assigned to your Sansa Clip when you connect it to the USB port.

In the “Drive Label” field enter something such as “Internal”

Leave the “USB Device ID” field blank.

Select “Playlists” on the left-hand panel.

Check the “Force relative paths” option.

(If you want to set up the MicroSD card, copy the “d_USBMass1.dll” file in your MediaMonkey/Plugins directory of your computer, naming it “d_USBMass2.dll”.  You will need to restart MediaMonkey for it to notice the new file.  Make sure you have a MicroSD card inserted in your Sansa Clip and repeat the steps above but select "d_USBMass2.dll under Tools/Options/Portable/Audio Devices and give it a “Device Name” such as “Sansa Clip+ External” and a “Drive Label” such as “MicroSD” or “External”)

Click the “OK” buttons to save your changes and return to the main MediaMonkey window.Your Sansa Clip should be listed on the left-hand panel above “My Computer”.

To send a playlist and associated audio files to your Sansa Clip, navigate to the M3U Playlist on your computer, or create one with MediaMonkey.  Right-click on the Playlist and select “Send To” then select your Sansa Clip from the list.

"

The Clip Plus will view files with the “Genre” tag set to “Podcast” (or varients such as “Podcasts”, “Podcasting” etc) strictly as Podcast files and not eligible for use in Playlists.  If you create a Playlist and it appears Empty in your Sansa Clip or missing entries for files you know are in your Playlist, change the “Genre” field for those files to something besides “Podcast”."

The trouble with this is that when you shuffle your music, those podcasts will also play. The podcasts will also be listed in the song lists.

i make things simple and just avoid using playlists, although a few times I did use the go list on the player.

Ah, well, preventing Podcasts from being mixed in when playing music in shuffle mode makes sense, except that if you are playing a Playlist and turn on Shuffle mode, it only suffles within that Playlist.  I can easily create a playlist that contains all the Music and none of the Podcasts on my player.  I can NOT easily retag all of my podcasts to make a pseudo playlist by creating a series with matching Album info and individually altering each Track Number field to get them into the desired order.  They could also have made the over-all Shuffle ignore “Podcast” files, yet still allow “Podcast” files to be included in Playlists.

I have a Sansa Express that I have used for years without all of these goofy issues.  I expected the Sansa Clip+ to act much the same, but the special handling of “Podcast” files has been a bit of an unpleasant surprise.  My primary use of my player  is to listen to podcasts in chronoligical order (I like to listen to news podcasts from different areas of the US, Canada, and the UK to get broader coverage of current events and different viewpoints.)  Playlists easily allows me to copy over my podcasts and have them in chronoligical order without any need to individually alter any of the files.

Keeping “things simple and just avoid using playlists” would mean that my podcasts would play in alphabetical order, jumbling up the news stories (I often get a few days behind), and any unfortunate podcasts with a name/album starting near the end of the alphabet would constantly get pushed to the end of the queue each time if I resynced before listening to every one of my podcasts first.

It sounds to me like the thinking about the Podcast files had a grain of good thinking behind it, but did not take nearly enough into account, and could have easily been made more general and MUCH more functional by merely providing a simple bookmark linked to each playlist file.  No need to check “Genre”, no need to check “Album”, no need to check “Track Number”. 

Many people want to choose play all and shuffle, and shuffle all their songs. Yes, you could assignall your songs the Rock genre and first choose Rock genre then play all with shuffle, but that is an extra step. I put all my classical music in the audiobooks folder as I don’t wan’t the movements of those to be in the song database.

" I can NOT easily retag all of my podcasts to make a pseudo playlist by creating a series with matching Album info and individually altering each Track Number field to get them into the desired order.  "

you can do it easily using the free software mp3Tag.

http://www.mp3tag.de/en/

I continue to have this problem and I haven’t had much luck figuring out how to retag files (everyone says it’s supposed to be easy; not my experience).   The Clip is terrific but remarkable unsuitable for podcast use, and that’s ALL I use it for, unless you want to use it to play one file at a time.    Assuming I eventually figure out how to use the “easy” retagging software (mostly my problem I acknowledge) is there anything in specific that the genre should be changed to?

What I really don’t understand is why this isn’t fixed via a firmware update.