Driver for ImageMate SDDR-89

Is there a driver for Windows 8 for the ImageMate SDDR-89.

From what I know, all USB devices don’t have a driver that can be manually downloaded. It uses the Windows preloaded drivers. Just make sure that you currently have the updates on Windows installed.


I have a SanDisk ImageMate 12 in 1 (model number SDDR-89) and a computer running 64 bit Windows 8.1. Windows automatically recognized and installed the card reader. It show up as “ImageMate 12 in 1 Reader/Writer” in Devices and Printers and as four removable disks in Windows Explorer.

However I had initall trouble to get Windows to recognize that the the card reader was connected. I then noticed that if I pressed the male mini USB (type B) connector on the Cable into the female mini USB (type B) connector in the SanDisk ImageMate my laptop would recognize it and automatically install it. No need to install a driver. I ended up removing about 1 mm of the plastic/rubber closest to the metal part of the male mini USB connector on the cable so that I don’t have to press the connector against the card reader.

Best regards



New to the forum!

I have the same device, ImageMate 12 in 1, model SSDR-89. It does show up in Devices and Printers, but not in Windows Explorer, so I cannot access any of the files on the SD card.

This is on a desktop, not a laptop, and no amount of extra shoving of the plug into the slot in the back of the computer seems to make any difference!

Anyone out there have any clues? Would be much appreciated!



:smiley:   Hi JimKenzie,

Dear member of SanDisk Community, welcome.

In Devices and Printers, the selecting and with right click, there is an option to activate?

Also, try on other PCs.


Regards, Alfred.                                                             (Google translated)

Hi Alfred:

Thanks for your reply!

Looks like I’m going backwards - tonight when I clicked on Devices and Printers within Control Panel, it didn’t even show up there!

I unplugged it, plugged it back in, and it did show up in Devices and Printers, but still not in Windows Explorer.

The ‘right click’ options are Eject (caused the green light to flash for a while; no other progress); Create Shortcut (can’t see that being worthwhile!); Troubleshooter (as usual with Windows troubleshooters, no joy); and Properties in bold face (under Hardware, it shows ‘Generic STORAGE DEVICE USB Device’ four times, presumably the four different card reader slots, then ‘USB Mass Storage Device’, and then below that panel under ‘Device Function Summary’, ‘This device is working properly’.)

Except it isn’t!!

No apparent right-click option to ‘activate’, unless I’m looking in the wrong place!

My other computer, a laptop, is inconveniently in for repairs today, so I can’t check it on that. When I did plug it into the laptop before, it still didn’t show up in Windows Explorer, but I wasn’t aware of the ‘Devices and Printers’ thing then. So when I get the laptop back tomorrow, I’ll try that.

Thanks again for your efforts!