Change the SansaClip Battery?

Can anyone comment on changing the Sansa Clip battery? The device connects fine to my computer but, no matter if I leave it charging, even overnight, won’t start on its own. The only thing I can think of is that the battery is fried. I’d like to change it on my own. Any thoughts?

Thanks, Mike

How long have you had it?  If it has been under a year, then you may just want to call Support and get it replaced.

If you really want to do it yourself, you’ll have to crack it open (use a hobby knife and cut/pry it open along the seam), then figure out the battery size (it’s a Lithium Polymer but idk the mA/hr rating or dimensions). Then find a source of LiPo batteries, you can try

A new battery is probably in the $10 - $15 range, maybe less if you get lucky and there’s a blowout sale… You might try searching the ABI (Anything But Ipod) forum for others who may have done this already…  

Be careful with the knife because if you jab the battery accidentally, it can erupt and spew fire and goo all over the place.

After desoldering the old battery and replacing it with the new one, you’ll need to glue the case back together. You Clip willl be uglier but at least it should work again.

Worked on a bunch of these. The battery is probably good. Most of the players have a broken red wire at the circuit board due to the battery coming loose inside the case and moving. The red wire breaks because it is the shortest of the three coming from the charging board mounted on the battery terminals. Have also seen a good amount of charging boards loaded with corrosion. Unwrap the insulating tape, clean the board, rewrap, and they charge fine. This is another hardware problem with these players. The batteries need to be glued down stronger to the shielding plate.

Hey 14124all  great advice,  I have had my Sansa Clip for 1.5 yrs and it just quit charging,  would play in AC but nada any other time.  I hacked the case and the red wire was broke. Re-routed the wire and re-sodered it and Eureka,  it now holds a charge.  Thanks for the heads up you provided for all who were willing to search!!!  Opps maybe I should have glued down the battery better,  Guess I might re-open an re-glue.  (kinda over worked the re- :wink:)