CF slot not recognised in USB 3.0 card reader Windows 8


I upgraded(?) to Windows 8 and now the CF card slor in my USB 3.0 all-in-one card reader is not recognised. The LED flashes continuously but the card does not show up in Windows. The SDHC slot is OK. I’ve tried different CF cards and the old USB 2.0 reader works with them.

Any thoughts? 

Any thoughts?”

Have you written to the Windows 8 support forum and the manufacturer of your USB 3.0 all-in-one card reader’s support forum and seen what they suggest?

Well it is a Sandisk card reader, which is why I posted here. I have since upgraded the bios and chipset drivers, both of which were said to improve USB handling, without result.

I report the same problem. My SanDisk card reader (USB 3.0) has worked well under Windows 7. I have just upgraded to Windows 7 this afternoon, and the CF slot no longer works. The SDHC slot is still fine. I think there is incompatibility between this reader and windows 8, on the CF slot. Can someone at Sandisk try to reproduce this problem? It’s frustrating as this reader is the only way I have to get photos into the desktop PC.

To elaborate, the blue light under the CF slot keeps flashing when the CF card is in it. Lightroom’s Import dialog freezes. The Computer window never shows the card.

If a SDHC card is put in, it shows up instantly.

The CF card is a Sandisk Extreme III 12GB and the SDHC card is a SanDisk Extreme 32GB.

Another update: if the CF and SDHC cards (see above post) are put in the reader, none of them show up. So the CF card jams the reader. Please some one help to resolve the issue.

It’s frustrating as this reader is the only way I have to get photos into the desktop PC.”

Until you get a fix I recommend you back out your Windows 8 upgrade. 

@ed_p wrote:

It’s frustrating as this reader is the only way I have to get photos into the desktop PC.”


Until you get a fix I recommend you back out your Windows 8 upgrade. 

No need for that. I have found out that it will work if plugged into a USB 2.0 port. There are other USB 3.0 card readers that work under Windows 8. 

Wow!!  Good to know.  Thanks for the follow up.

Hi Ed_P: are you an employee of SanDisk? Why I ask is I hope someone at Sandisk notices this thread and takes action.

narrowgauge: thanks for the tip! It could probably be more useful to someone else than my particular situation: the files from the Nikon D800E are routinely 50-70MB a pop, so I really need the USB 3.0 speed.

I have been on to Sandisk support about this. They have no answer yet. I can’t give them the information that they have asked for because I have been locked out of my account.

Hi I’m also having this problem and have to resort to using usb2 to read my cf cards. Is there a solution in sight or should I just get another non Sandisk reader?

This is what Sandisk technical support have told me today:

> There is indeed an issue with the compact flash slot on Windows 8 when being connected on a USB 3.0 port

> We are currently working on this to fix it.Until then we would suggest you to use the reader on a USB 2.0 port.

> I am really sorry for any inconvenience this may have caused you.

> I will update you as soon as we fix this issue.

1 Like

I have learned, via the Microsoft Answers forum, that Sandisk have released a firmware upgrade for this: It worked for me.

1 Like


I have a SIIG USB 3.0 Multi Card Reader model ju-mr0712-s1 that had exactly the same problem. Apparrently the actual hardware is made by Realtek and rebranded as SIIG.

SIIG tech support was pathetic and said since it wasn’t tested on a Surface 3 Pro, they couldn’t help me.

Since most people aren’t the first one to discover a computer problem, I started searching and found this thread. Since I had nothing to lose, I downloaded and tried to install the firmware update mentioned here.

It worked perfectly! Thanks SanDisk for fixing SIIG’s problem!!!

Here it is 2019 and I just ran into this old problem, connecting my ImageMate card reader to my new laptop’s USB 3.0 port (Windows 10).  The firmware update is still available and it worked fine.  I had to run it twice though – the first time the updater complained about a flash error.  Now it reads the CF card like a champ.  Thank you narrowgauge!