can't boot a Mint Cin 17.1 live Sandisk Ultra Fit 3.0 32GB

I’m successfully running Mint Cinnamon 17.1 on my laptop as the only OS, and have successfully installed and run a 17.1 live version from a PNY 2.0 8GB thumb drive using Unetbootin.
But when I successfully install the live version onto a Sandisk 3.0 32GB Ultra Fit thumb drive, using the same method on the same laptop, during the Sandisk Live boot, I get the message (initamfs) “Unable to find a medium containing a live file system”.

After formatting again to FAT32, I’ve tried Linux USB Image Writer and Unetbootin again, each attempt resulted in “unable to find a medium containing a live file system”. Even though the ISO is successfully written to the drive.

I’ve tried booting from different 2.0 USB ports. Same failed results.

GParted shows the Sandisk partition flagged “boot” the same as the PNY drives.

So I then used terminal command: ‘sudo dd if=/dev/zero of=/dev/sdb bs=4096’ to completely zero out the SanDisk.
I formatted FAT32 again.
I checked the downloaded ISO MD5 for accuracy.
I used Unetbootin to write the ISO to the USB stick.
With the stick still in the port I restarted and opened the boot menu.
I checked the BIOS boot order. USB HDD: SanDisk-(USB 2.0) was listed first. I selected it.
I got the same failed results: The Linux Mint 10 sec. to boot screen opens, then the screen with the LM logo appears.
After awhile the same message appears:
“BusyBox v1.21.1 (Ubuntu 1:1. 21.0-1ubuntu1) built-in shell(ash)
(initramfs) Unable to find a medium containg a live file system”.
I tried to boot the SanDisk on another laptop with the same failed results.

I used the terminal command to list and include hidden directories “ls -a” and listed:

. casper-rw ldlinux.sys preseed ubninit
… .disk MD5SUMS README.diskdefines ubnkern
boot dists menu.c32 syslinux.cfg ubnpathl.txt
casper isolinux pool ubnfilel.txt

Which is exactly what one of my functional Linux Live PNY sticks  lists.

So my last attempt was to clone the functional Linux Live PNY USB stick to the Sandisk USB stick. After formatting FAT32 again I used terminal command:

sudo if=/dev/sdb of=/dev/sdc bs=32M

It cloned perfectly, but again the SanDisk would start to boot with Unetbootin, then “unable to find a medium containing a live file system”.

Is there any way to use SanDisk Ultra Fit 3.0 32GB Flash Drive for a bootable Linux Mint Live OS?

1 Like

Very strange IMO.     

What does gdisk /dev/sdb1 show?  Assuming sdb1 is your USB drive, change accordingly.

Try Easy2Boot. See if it helps.

Thank you for your reply,

This the first time I’ve ever used gdisk. I’m learning alot trying to solve this problem.

Hear is what  gdisk /dev/sdb1  lists:

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present

Found invalid GPT and valid MBR; converting MBR to GPT format
typing ‘q’ if you don’t want to convert your MBR partitions
to GPT format!

Exact type match not found for type code F400; assigning type code for
‘Linux filesystem’
Exact type match not found for type code 1000; assigning type code for
‘Linux filesystem’
Exact type match not found for type code 7400; assigning type code for
‘Linux filesystem’

Warning! Secondary partition table overlaps the last partition by
3466974709 blocks!
You will need to delete this partition or resize it in another utility.

Command (? for help):

On this disk,  /dev/sdb,  I GParted a boot partition, FAT32  /dev/sdb1,  and an ext2 partition /dev/sdb2, labeled casper-rw,  to have a larger persistence storage than the FAT32 allowed 4GB. But even without setting up any persistence, it still was unable to run the Live stick.

Since I’m not familiar with gdisk, can you advise what I should do to make my SanDisk stick boot linux Live.

Thank for leading me in another direction,


1 Like

Since I’m not familiar with gdisk, can you advise what I should do to make my SanDisk stick boot linux Live.

Did I mention trying the Easy2Boot app?  :wink:

Yes you did.

I won’t go any farther with gdisk.

I’ll give Easy2Boot a try.

Something new for me to learn.


Today I called SanDisk support.

I explained that the BIOS boot order lists: “USB HDD: SanDisk-(USB 2.0)” first. But during the boot sequence, I get a message, “Unable to find a medium containing a live file system”. Yet when I examine the contents of the disk, all the system files are there. Phone support could not help with Linux or boot issues.

So I e-mailed customer support a second time and was told: “we can replace your flash drive with another drive that will be detected as removable drive in your computer”.

I gave them the product code barely visible on the drive, was sent an RMA and a shipping label. And returned my drive today.

I will post a follow up when I receive the replacement drive. For anyone that might be experiencing the same problem booting Linux Live from a Sandisk SDCZ43-032G-G46.

Thanks to everyone for their suggested help in this matter. I’m learning from you guys.


1 Like


I am having a similar issue with booting Linux on SanDisk Ultra Fit 32 GB. In January, I first bought a single such USB drive and I have installed Linux on it like on usual disk. I could boot it without issues, the product code of that drive was BM141 0 24848V.

However, two weeks after that, I bought a set of 15 such drives, but the product code was BM141 2 24848V this time. I can’t boot Linux - during the boot procedure it essentially hangs as it’s not able to find the USB drive and I get stuck with the “initramfs” prompt. However, I have discovered a workaround: simply unplug the drive, wait 2 seconds and replug it into the computer. Now type “exit” and press ENTER. The system should continue booting.

I have just bought another such USB drive, with yet another product number (this time from a different reseller): BM150 2 24846D. This one also has the same booting issue. I need these drives for a workshop, so I have 3 more weeks to either make it work or simply buy something else. I’d hate to do this as these really look sexy and are very fast.



1 Like

I don’t know what you’re using to put Linux on your USB drives but Easy2Boot is a good tool for doing that.  And unlike many older tools used it is current and maintained.  It also supports putting multiple systems on a drive.  Check it out. 

I’m having the same problem. In my case, I’m not creating a live USB, rather, I’m installing Min Cin on the onto the Sandisk  Ultra Fit 3.0 32GB from the live CD.  I install the bootloader on the USB drive as well.  When I boot the laptop, I select the USB drive.  The same error happens at this point, and the procedure to unplug drive and “exit” works, but this is a terrible work-around.  Also, I have no problems with the exact same setup with other USB 3.0 32 GB drives.  My drive is BM141124848V / SDCZ43.  I’m really disappointed in the drive because I bought it specifically for booting Mint independent of Windows.

1 Like

I should add that the same problem happens with Fedora and trying to boot from a Sandisk  Ultra Fit 3.0 32GB.

Update: I tried to format the USB drive in Windows 3 times, FAT, exFAT and NTFS (full format).  Every time, the format fails about 1/3 of the way through.  I’m using a USB 3.0 hub out in the open, with plenty of airflow.  When I pulled out the drive, I was almost burned by temperature of the metal USB connector.  There is definately a systematic problem with these drives, and this has nothing to do with Linux.

When I pulled out the drive, I was almost burned by temperature of the metal USB connector.  There is definately a systematic problem with these drives, and this has nothing to do with Linux.

I agree.  USB connectors do not get that warm.  Return it.

Just bought a SDCZ48-032G from Best Buy today to run Mint 17.1.

Exactly the same problem, but for me the workaround doesn’t work. 

  • Chris

In my prior posts, I noted I had the same boot problem, and couldn’t full-format the drive.  Also the drive was extremely hot.  Same problem with 2 drives.  I just exchanged the drives for 2 new ones.  I still have the same problem booting Mint from an Ultra Fit – which is very disappointing.  The overheating and full-format problems (in Windows) apparently have been fixed in new versions of this device, at least.

Two weeks ago I returned the SanDisk Ultra Fit 32Gb, product code BM150124846D because it would not boot Linux.
Yesterday, I received from SanDisk                            product code BM150224846D
It won’t boot Linux either, no matter what method I use to write the ISO to the disk.
However, no boot problem at all using a PNY 8GB 2.0.
So, the Ultra Fit may be a great drive for storage, just don’t get one to boot an OS.


1 Like

I have received the following feedback from SanDisk:

Dear Nejc,

We understand that you cannot use your Ultra Fit drives as bootable devices. We would like to inform you that we atSanDisk have not tested our flash drive as a bootable device. SanDisk does not provide any utility or instructions to make the flash drives bootable.

So in that case we cannot assist you further with this issue.

Very disappointed.

For my own info nejko did you try the Easy2Boot app to put your Mint on the drive?

daBrewer & nejko, on this Easy2Boot link of tested systems:

"49. Linux Mint   14 Nadia linuxmint-14.1-cinnamon-dvd-32bit.iso "

If the app didn’t work for your version of Mint contact Steve Si, the creator of Easy2Boot, and he will help you.

Yes, I have have made the SanDisk Ultra Fit 3.0 32GB stick a U2B drive.

I copied the Linux Mint Cinnamon 17.1 ISO to the U2B Main Menu.

When I boot the SanDisk USB stick, the U2B Main Menu opens.

I select   “linuxmint-17.1-cinnamon-32bit(1)”

I get the “LM” symbol on the screen.

Then  “(intramfs) Unable to find a medium containing a live file system” 

Same as all other tried methods of booting Linux from a SanDisk Ultra Fit.

However, a PNY 2.0 8GB drive boots without fail.

In my previous post I typed U2B instead of E2B (Easy2Boot)