Brand new Extreme USB 3.0 64 GB, unusable

Just received from NewEgg a new USB drive, plugged into my 2012 MacBook Pro with USB 3.0 ports, drive was visible in Finder, was empty (should I have seen some files already on it?). Tried to copy one small file to it, got some message about “discovering files” and it never went away, after 5 minutes or so. Unplugged drive, plugged back in, ran Disk Utility, tried to Repair, said disk is unrepairable in red letters. BTW, this is OS X Mountain Lion.

Plugged the new drive into Windows 7 64-bit system with USB 2.0 ports. Drive doesn’t appear in file explorer. Run Windows’ Disk Management application, it’s visible there, but I can’t get it to mount. Delete the partition, no problem, but then all the options to repartition are grayed out.

So, clearly this is an unhappy drive.

Then I notice that others are experiencing the same sorts of problems, and basically nobody can get it to work under MacBook Pro. Strange.

I wouldn’t mind waiting for SanDisk/Apple to get things straightened out, if the drive at least worked on my Windows systems.

I downloaded the HP flash drive formatter utility that sometimes can format flash drives when Windows can’t. I couldn’t format this drive with it, but oddly enough it did seem to make Windows see the drive and offer to format it itself. Using “quick format” option, it took Windows at least two hours to format the drive. But, as with my MacBook Pro, although the volume shows up in file explorer, trying to copy a file onto it results in a “discovering files” message that never goes away (at least not in the couple of minutes I waited).

Yes, the Extreme USB3 drive seems to have a compatibility problem with Macs.

I have the same drive and it works fine in Windows.

But when I plugged it into my 2011 MBP, it took a long long time for the drive to show up, and when it finally shows up, I cannot read, write, or even format the drive.

Guys, same problem here, but wierder : Win7 recognises the drive if its on the scsi/usb2 port, NOT on the USB 3.0 (blue) port.

Could be a port problem, except that ALL my other USB drives, both portable 1tb, portable 1.5tb, fixed 1.5tb vault, and another flash 32MB drives, ALL USB 3.0, do work on the laptop’s same USB 3.0 port.

Only this MF doesn’t, it’s not recognized, doesn’t show up on any disk management utility, when is on the USB 3.0 port.

What a let down! A 70$US flash drive that is slow as a 2.0!  WTF did I believe it was worth the money? I’ll never will buy anything from Sandisk! Pure deception!

In the end, I went through these forums and there is very little actually usefull help…by the way, before anyone calls me names, no I’m not a dumbwit, it’s the legitimate article, at a reputable computer equipment dealer, over the counter, proper packaging, so no, I didn’t bought fake and expected to pay little for a lot; I actually paid sticker price.

Rgds (sorry for venting)


I also have the same issue. I find a web site comparing usb flash drives and how this is the best measuring performance and cost. What a hard lesson to learn. On a MAC it will not format at all. It says it has a problem with the last byte. I tried to format the drive in Windows and can only get exfat to work. I know next to nothing about Linux but created a Gparted Live disk on a usb stick. I booted this up on a Windows computer and the Linux utility allowed me to delete the partition and format with NTFS. So I brought the USB stick back to running on Windows. It sees the drive letter but completely locks the computer when you try to access the drive from explorer, command prompt…I tried chkdsk and it did no reads or writes. I tried a format and it did no reads or writes. This 64GB flash drive is unbelievable. I hope they don’t delete this so everyone can see what a waste of money and time this drive is for me. I want to install an OS on it since it’s USB 3.0. I’ve done this with other USB sticks for both my Mac and my Windows computer with no issues. At this point I’ve wasted so much time on this that I really just want to throw it away. The only thing left to try is to go back into Linux and try one of the other formats and see if I can get FAT32 or something else to work. Wow, who can believe in 2012 that this kind of problem still exists. Unbelievable…  

On a MAC it will not format at all.”

and see if I can get FAT32 or something else to work

When it leaves the factory it is formated as FAT32, did you try using it that way before you reformated it?

At this point you should contact SanDisk and see about returning it.  Probably best not to tell them you formated it before using it.

Pretty sure it came Exfat but I will believe you.

Same problem here.  I tried the drive in both a USB 2.0 and a USB 3.0 port on my windows 7 PC.  The system froze at “discovering files” when I tried to copy files to it.  So I tried formatting (per Sandisks suggestion) and now I cannot format or partition the drive.  This is the second drive that I have tried (both from Newegg) and I still have the problem.  I think this is a junk product right now that Sandisk tried to rush to market (since they dont have a usb3.0 flash drive like other companies) and there are still a bunch of bugs to be worked out.  I am going to try to get my money back.  I am highly dissatisfied right now.

P.S. the drive came formatted as FAT32.  I have tried NTFS, FAT32, exFAT and none have worked.  I have also tried the HP utility per sandisks cusomer support.

Same here on my macbook retina…

Mine is the same way. Can only be formatted as FAT32 through the HP format utility or to exFAT. Nowhere in the drive description Sandisk says the drive has this limitation, which is a serious problem, as some devices can’t read exFAT (MS patented format IIRC) and FAT32 won’t support files bigger than 4GBs. A XXI century, 2012 made 64GB drive shouldn’t have this limitation, or it should be clearly stated on the product specification.

And please, don’t tell me I shouldn’t expect the drive to work with OSs that are not from MS, or with files larger than 4GBs, specially as this drive is fast enough to be a boot drive, or to be used to transfer big files between devices.

Nowhere in the drive description Sandisk says the drive has this limitation,”

Really??  It doesn’t say “reformat before using” or “must be formated using Windows or an HP utility found on the 'net”.  Obviously a documentation oversite. :smiley:

Of course there is the possibility the USB stick was designed to be used as manufactured. 

I will give you the concern about 4GB files but maybe the manufactured format supported files that size, somehow.  Maybe the SecureAccess app that came with the USB stick doesn’t have that limitation.  But since you quickly formated it without testing it we don’t know.  And since I don’t have $100US to spend on one I can’t test it out to find out for you.

Somehow though in the back of my mind I seem to recall that there was an easy way to format USB sticks in Windows 7 to NTFS.  If I find a link for it I will edit this later.

No link needed.   I just formated a smaller USB stick using this procedure on my Win 7 64-bit machine:

open a Command Prompt window and enter FORMAT *:  /Q  /FS:NTFS   where * is the drive letter of the USB stick. 


Unfortunately, this procedure does not work. It was one of the many I already tried.

I don’t know if you mistook me for someone else, but I never said I formatted the drive before running the Sandisk app. It is just that the drive did not work in the state that it came out of the box. My first action was to make a folder in order to store all the files that came with the drive, but a folder couldn’t be created.

Well, there has been something like 10 years that I have used a drive that needed a special program just to work as advertised. Sure, blame the user. It should have known better than to think this drive would just work.

Unfortunately, this procedure does not work.”

Error msg??  End results??  Need more info.

Does Sandisk have some kind of low level format utiity for their drives?

Not that I’m aware of, which doesn’t mean one doesn’t exist.

Sometimes Windows doesn’t allow formatting USB keys to NTFS unless the policy for them is changed to “Optimize for performance” in Device Manager.

Actually I saw a write-up about changing the setting in device manager to get NTFS, It still didn’t work. The fact that U can use gpart live in a bootable disc and only get fat32 to work says volumes. Exfat is not supported. Both fat32 abd exfat seem to work. 

There are so many better choices out there that do not have these limitations. The Sandisk engineers and their sales and marketing people should be ashamed of themselves,

I’ve tried many and so far my favorite is the A-Data USB 3.0. The S102 is great and the N005 Pro is even better. I like the Corsair trash can for durability. Maybe one day someone will put together a table of USB thumb drives and the features that are supported.

I actually do understand Sandisk taking this position to limit any journaling on the thumb drive They should just be more up front with their customers.

Any news on this front?

I plan to purchase one such drive, but if this is the support I’ll get in case of trouble, I might as well pass.

@dbaps wrote:

Pretty sure it came Exfat but I will believe you.

Here they tested it and you can see it came with FAT32.

if this is the support I’ll get in case of trouble, I might as well pass.”

What kind of support did you expect this user group to provide you?