32GB Sandisk Micro SD suddenly stopped being recognized by Galaxy S3 phone

:confounded:!!!sandisk is ■■■■■!!!:angry: i dont buy anymore sandisk products

grrrrrrrrrrrrrrr…

:confounded:!!!sandisk is ■■■■■!!!:angry: i dont buy anymore sandisk products

grrrrrrrrrrrrrrr…:flushed:

i brought two scandisk Ultrausb 3.0 32g pens in the last two months both stopped working for no reason,

its a complete rip off wont be buying anymore from scandisk highway robbery

@manpic wrote:

i brought two scandisk Ultrausb 3.0 32g pens in the last two months both stopped working for no reason,

its a complete rip off wont be buying anymore from scandisk highway robbery

Have you tried contacting SanDisk (not scandisk) for a warranty replacement, or do you think trolling on a user’s forum will rectify the situation for you?

Tapeworm,

There’s no need to be abusive. You are talking to a customer of Sandisk (even if they have made a small mistake with the name).  If you have any evidence that this is a troll, do share it, otherwise be more polite.

There is obviously a problem with thes (sorry, these) cards.  I have had a 32gb card do the same thing in a Galaxy S4 and a 128gb card in a Galaxy Note 4. Both lost all the data on them, so now do we trust them or back them up regularly or what? Samsung gives us the facility to move apps to the SD card, so suddenly losing apps as well as data can be very inconvenient.  We do need to rely on the SD card from hour to hour even if we back up every day.

Both mine were replaced and upgraded (the 32gb to a 64gb and the 128gb to a higher class) by Sandisk, but not without a lot of messing and sending the faulty cards back.  It is, however, as you suggest, always worth taking the case up with Sandisk who do not quibble providing the card is genuine.

I only wanted to share with you my experience of recover files from my 64 GB flsh memory.

Please do not trust to use Recure Pro software from LS Technology International. Their software is very awful. All recovered files are mixed up with different name. Very poor customer care.

Instead I realy recommend use EASSOS Recovery software: http://www.eassos.com/

Excellent software with very high trusted performace.

Until a few days ago my Sandisk card was working perfectly. Then I got a message on my Motorola Moto E 2nd edition phone indicating that the SD card was not inserted. I’ve been getting this indication intermittently since then. I can read the card on my laptop; it shows what looks like a standard set of files dated 11/30/16. I can think of three possible causes: a software defect, a defect in the card itself, or a bad contact between the card and the socket I’ve removed and reinserted the card several times, and also tried cleaning the card’s socket with an eraser. Does anyone have a suggestion as to how I might determine which of the three causes applies, and if so, what I can do about it?

This thread seems eternal, and pretty much a common problem of the failure of Sandisk 32 Gb Ultra micro SD cards, and I am one!

Loss of material - photos etc is one issue - Yes, agreed we should back up on a regular basis.

But, there is also a responsibility for the manufacturer to accept there is a serious problem, accept that customers are dissapointed, accept that they have not adequately addressed the problem, accept that they do not appear to have made any attempt to apolgise for what is obviously a faulty product, accept that the least they could do is to offer a free replacement card to those that have experienced the failure of a product that does not meet the requirement for which it was purchased - i.e. the reliable digital storage of data. And, accept that customers not receiving sufficient support are more than likely to look to another manufacturer for the supply of more reliable data storage.

HALLO SANDISK - ARE YOU RECEIVING ME???..OVER.