32gb micro SD has no partition table

Ive been having problems with my digital camera and thought it might be the sdcard. So I checked it and it had a small area that was unallocated and then around 31gb formatted in FAT32.  I delered all partitions and then made a single one and formatted it to FAT32 but it locked up and eventually ity came out and ever since then It wont let me do anything.  If I try to add a new partitiion I just get a error that there is no partition table.  I tried creating a new table anf it seems to work but when I try to create a partition it keeps kiving me the error "no partition table. So it goed round and round and getting nowhere.  This card is only about a month old.  I have Linux and windows and usualy use Gparted in Linux and a similar program in windows but get the same result with both.  I did try doing it wirth the command line in Linux with Fdisk and Gdisk but get same results as well.

Even when it says its been successful it hasnt,

Please can someone solve this?