"you need permission to perform this action"

hello, i got a microsd card 32GB and my computer wont let me use it, first i says there is no memorry on it then when i try to move my music to it it says that “i cant perform this action” HELP!!

Are you using the SD adapter that came with the card? I have had trouble with the SD adapters that came with my Sandisk microSDHC cards. One didn’t work at all, and on one the write protect slider kept sliding into the write protect position as I inserted it into the slot. It finally worked fine when I taped the slider into the unlocked position on the adapter.


I know I’m too late for this reply but this method worked for me. So, I’m just putting it out there so that other people too can refer to it. :slight_smile:

Change Permissions

Normally this error will be related to an actual permissions problem, so let’s at least get that out of the way before trying other options.

Go ahead and right-click on the folder and choose Properties.

Next you want to click on the Security tab and then click on the Advanced button.

Now you want to click on the Change Permissions button at the bottom left.

Now is the fun part. It definitely looks complicated and that’s why you have to do this section right, otherwise you’ll think you

set the permissions right when, in fact, they are wrong.

First of all, go ahead and check the Replace all child object permissions with inheritable permissions from this object box.

Then go ahead and uncheck the Include inheritable permissions from this object’s parent box. When you uncheck the box, you’ll get a warning box where you’ll have to choose from Add or Remove. Go ahead and click on Add.

Now a normal folder that is deletable should look something like above with SYSTEM, Administrators and the user (Aseem) having Full Control with the Type set to Allow. At this point, you need to see what’s different and get your permissions to look like this using the Add, Edit and Remove buttons.

If you see any permissions with Deny in the Type, go ahead and remove them. Next make sure to add your username and the Administrators group and give them Full Control. Just click Add and type in the user name for your Windows account and then click Check Names. My Windows user name was Aseem, so I typed that in and clicked the button and it automatically changed it to WINDOWSMAC\Aseem.

Do the same thing for administrators, just type the word and click Check Names. If SYSTEM is not present, go ahead and add that also just to be on the safe side. When you are done and the permissions look correct, go ahead and click OK. It might take some time if the folder is large and has a lot of subfolders. Once it’s complete, go ahead and try to delete the folder!

This answer from Microsoft might be helpful too. You can always look at alternative ways to fix it if this one doesn’t work for you.

SanDisk is a very bad company that manufactures defective and useless flash drives. I think that we should throw the flash drive to the head and kill him… Very bad flash drives…

After a Samsung update earlier this spring, phones would read SD cards but be unable to write to them, even with permissions allowing it.

Has anybody had any luck resolving this? Samsung isn’t responding in forums, and a lot of unused storage space is going to waste.

I’ve tried downloading different file management apps and none of them help. Unmounted/remounted the SD card a couple of times… nothing’s working.

If anyone has advice, please let us know! You could make quite a few people very happy.