Will ReadyCache have a driver for Windows 10?

@rmast wrote:

After fighting a night and a day I now have readycache installed again. You need this expresscache version: http://answers.microsoft.com/en-us/windows/forum/windows_10-win_upgrade/sobre-o-expresscache-do-notebook-asus-vivobook/0519b546-a00f-42ae-b809-d8931637beb7?auth=1




It ended up with the message that I already had a newer version installed.


Then, when it decompresses it says it produces a file called expresscache.msi.


This file can be found somewhere around  %LOCALAPPDATA%\Temp{E1E38DF6-5231-4B7C-B798-0708709777BC}. In any case it must be a new directory in this Temp-directory.


If you then start this msi with 
cd %LOCALAPPDATA%\Temp{E1E38DF6-5231-4B7C-B798-0708709777BC}

msiexec /i expresscache.msi /Lv* output.txt


You can watch in the log in output.txt whatever remnant is obstructing the install. I succesfully forcefully removed the found GUID with a trial of Revo uninstaller pro 3.1.4.


Now let’s see whether this thing will let itself configure as I already tried the primocache trial on the 32 GB SSD, so it has to be manually reconfigured…

Interesting what you have found here but I need the 32 bit version of the driver. This one is 64 bit.

Maybe SanDisk might even get their act together and sort it out quickly. If they don’t they will loose a lot of customers for this product.

They basically don’t seem to care about customers though.



@rmast wrote:

Luckily the Sandisk 1.3.2 version I already had running on Windows 7 is now progressing further in the install and asks me to restart…

Your very lucky as you are coming from Windows 7 to Windows 10. I have the failed situation of going from Windows 8.1.1 to Windows 10 Pro and I can’t either un-install or re-install currently and SanDisk support seems to be usseless.



“Expresscache can not launch. Try using the original user account for the first time.”

As far as I know the ‘user account’ hasn’t changed during the Windows 10 upgrade…

Removing the 1.3.2 driver again gives a 1603… I’ve seen that before… Running in circles…

@rmast wrote:

Removing the 1.3.2 driver again gives a 1603… I’ve seen that before… Running in circles…

Completely agree.

SanDisk / Moderators do something about this urgently…



The uninstall error you are seeing is not related to Windows 10. Expresscache has two elements.

  1. The Expresscache driver
  2. The Expresscache GUI

Both of these elements show in the control panel. The driver shows as Expresscache and the GUI shows as Expresscache app. If you uninstall Expresscache (the driver) first then try to uninstall Expresscache App (the GUI) uninstalling Expresscache app will fail. This is because the GUI is trying to uninstall the driver and it is no longer there.

If you are runing into this issue you must manually uninstall the GUI. Going forward you will need to uninstall expresscache app and it will remove the driver as well.

That said Expresscache still is not compatible with Win 10 at this time. From what I understand they are working on it but I have not seen any additional info on any update or release for this software. 

See the link below for manual uninstall instrucitons. 


I have the same problem ¡¡ It doesnt work with windows 10

I recently came across this thread which I will be following with great interest.  I have an 18 mo HP Desktop equipped with a ScanDisk Ready Cache 16 Gb drive.  Fortunately I have not yet updated from 8.1 to W-10 because I came across this issue just moments before I was ready to download/install W-10.  I hope there is a solution for this soon because this cache drive does wonders with my machine and I wouldn’t move to W-10 without it.

I read ‘readyboost’ (standard solution of Windows) should be able to handle more than 4GB on a non-fat drive from Windows 7on … Going to try that…

Fast formatted the drive to NTFS with driveletter, claimed it completely for readyboost from the properties of the driveletter.

It seems to suck up some data, though it’s only passed the 500 megabytes yet after a few reboots, (visible with perfmon) so it’s not very quick.

The purple line of ‘read from cache’ seems to jump up for starting the apps I often start (all the browsers and Word), however when I restart the performance seems to drop again, so I’m not sure whether all speed comes from the Sandisk SSD yet.

At reboot I still have to await some starting processes till it responds to the mouse, hope the crisp response returns…

It seems to clear the cache at reboot… As readyboost should speed up reboot this should be possible to solve…

It’s not Readyboost that is supposed to speed up booting, but Readyboot. (The ‘s’ missing)

For securityreasons Microsoft has crippled Readyboost with a compression/encryption algorithm which forces clearance at reboot, which is not possible to turn off for a normal person, even with some registry experience or access to a policy editor on a professional-machine. Probably only someone who learns how to remotely install windows in an enterprise will obtain the knowledge to turn off the encryption which is rumoured to cause cache-clearance.

I switched back to the PrimoCache-trial. Still 58 days of the trial left to await a solution from Sandisk…

What a mess.

How does a company like Sandisk mess up like this?

It still blows my mind even though us older users have seen it before.

We have seen lack of support or quality checks for the same product.

If they have to re do the software then it could take many months.

It seems like they have only realized they need to update their product just now

after windows 10 is released. That’s terribly dumb in this day and age.

What are the sandisk bosses really doing in the back office?

What are the sandisk developers doing? How the hell do they stay employed.

How do you folks let the customers down like this on the same product - repeatedly?

It’s now Friday the end of the week that they said to me that they have a solution and still nothing has arrived in my email.

I’ll wait till Monday and then start chasing them up.



I hope they are going to release a driver in the next few days or I’m going to sue them. Windows 10 is being tested since January and they still don’t have a driver. My clients are complaining.

 They need to provide updates and support for their products. It’s URGENT.


eBoostr should also work for cache retention after a reboot, but the trial is more restrictive.

Current 1.3.2 seems to run fine on a W10 x64 desktop, but it was a clean OS install (after the upgrade). I haven’t experienced any sudden cache loss after reboot, except for the usual stuff that should cause it by design (large updates, defrag, etc).

Ok, I will try 1.3.2. once more… Use of Revo uninstall after the logging trick I wrote before in this thread lets me reinstall that one from scratch.

At this moment I use the PrimoCache trial, that gives crisp speed and still 56 trial-days left.

Again “ExpressCache can not launch. Try using the original user account for the first time.”.

I’ll try to uninstall the app and the driver separately…

Still the same problem. If I launch eccmd -info it says:

C:\WINDOWS\system32>eccmd -info
ExpressCache Command Version
Copyright® 2010-2014 Condusiv Technologies.
Date Time: 8/10/2015 15:14:14:870 (PC_VAN_GEBRUIKE #0)

Failed to retrieve product license information.


Should I reactivate it somehow?

I runned the installer again, and this time with log. Apart from that I executed both the inf-files in
C:\Program Files\Condusiv Technologies\ExpressCache\excfs and 

C:\Program Files\Condusiv Technologies\ExpressCache\excsd

Now I don’t have the licence message anymore and the commands

eccmd -partition


eccmd -format

are running again.