Trim support on Sandisk Extreme Pro 1TB in Linux

The thumb drive is marked Extreme Pro 1TB, SDCZ880-1TB: when I run the Sandisk Dashboard in Windows, it reports the model as being Sandisk SSD Plus 1000GB. The Dashboard also reports that the firmware on the drive is up-to-date.

Anyway, if I format the drive NTFS and try to Trim it using the Windows drive properties Optimise button, Windows reports it as being a hard disk drive and not a solid state drive, and so I can’t Trim it. If I run the Sandisk Dashboard, under the performance tab it does allow Trim to be run. However, I actually want to use the drive on a Raspberry Pi 4, and when I format it ext4 and interrogate it there for Trim support by getting it to report the Maximum unmap LBA count and Logical block provisioning, they are both reported as zero, which indicates that Trim is not supported. I was previously using a 256GB Transcend Jetflash 920 thumb drive on the RPi, and Trim works fine on that, but unfortunately I was running out of space on that drive, hence the purchase of the Extreme Pro.

Any suggestions on being able to run Trim on this drive with Linux?

The usb controller must support trim correct, many usb sata enclosures also had this issue, if the controller doesn’t pass trim, there is no way around it.


But if the controller in the drive doesn’t support Trim, then why/how does the Sandisk Dashboard say that it does and provide a button to run Trim:

Windows and Linux are telling me that it doesn’t support trim, whereas the Sandisk Dashboard says the opposite. Is this just a case of the manufacturer’s software lying about the capabilities of their hardware?

Maybe its a proprietary feature to the drive?

The Dashboard is showing the Sandsik SSD Plus not your extreme pro. Is that your system drive?