tags on M250 ?

i have m240 for long time now and just bought M250.

usually i use tags editor to sort the songs that i want into an “album” and then transfer them to the player. in the M250 he display those songs as “unknown” while the same folder in the M240 gets the album name that i gave it.

anyone ?

not sure? Are you in the same mode on both players?

My M260 does the same thing and I suspect it is buggy firmware/software.   I have checked the ID tags many times and there is no reason for it to happen.

Sansa won’t admit and fix the problem.

Or it could be you need to update the version of the ID3 tags to work with a newer firmware…just a thought…

I’m having the same problem with my m250 now. I’ve had it over year and once in a while would see some goofy sorting and/or tracks disappearing or the “unknown”  album, etc. phenomenon.
Usually, it cleared up after I took some items off the unit and put them back on again, but not this time.
In playing with it, I’ve made some observations that, as of yet, aren’t helpful, but might prove to be clues.
If I remove everything from the unit then copy it back on again (I always work in MSC), the result is two files showing as “unknown” album. If I then copy those two files onto the unit in a different folder, they cease to be “unknown,” but two other files show as “unkown.”  And so on.

It’s almost like the index is full, and just pushes a few tracks out to make room for a couple more.

At any rate, I’m pretty sure the problem is the not the files themselves.

I’ve also tested on a coule of different USB cables and it’s not a cable issue.

I’ve also updated the firmare and it’s not a firmare issue.

I still haven’t figured out what causes this problem or what exactly it is, but I do have a workaround.
I’ve found, so far, that when tracks show up as album “Unknown,” I can make a copy of the “unknown” track on my PC, then rename it and copy it to the M250 into the same folder as the file the m250 isn’t indexing properly.
The result, so far, as been that the copied file will show up with it’s tag info properly indexed.

However, note: if I delete the file that showed as “Unknown,” and then copy it back onto the unit again, it doesn’t solve the problem.

Doesn’t make a whole lot of sense, but it works.
The workaround also proves that the file is not the problem. It’s a problem with the device.

Still love my m250 though, warts and all.

Message Edited by aharown07 on 12-19-2007 03:20 PM

The id3 tag issues has just recently begun to tick me off.  I’ve downloaded and begun using an editor to change the tags and after I’ve edited the files the player shows the fields as unknown.  I’ve tried two different editors with the same result.

OF INTEREST: While these two programs didn’t give me tags my m250 could read the original files ripped with musicmatch did.  Also, after I used an editor that resulted in the unreadable tags I used XP to “change” the id3 tag. (Right click, properties, advanced tab)  I say “change” because all I did was double click to get me so I could change the field and then hit apply without changing anything.  I then sent the file to the player and it could read the tag.  Stupid limitiation, but at least I know it’s not the particular unit that is defective, it’s their lines software.

Nootherchoice, I don’t see an ability to edit tags in XP by right clicking an MP3 file. Does the file have to have tags already? I think some of mine do, but I’m not sure.