SSD Ultra II 480GB - Spikes/Lags


I recently bought an Ultra II 480 gb SSD.  I fresh installed windows 8.1 with all updates installed and from the first minute I noticed that when I’m trying to write big files to disk, or unzip big files the system starts lagging. Specialy when I have some browser open or doing something in parallel, system does like it cuts internet connection ( but it is connected ) , windows explorer is hanging , I can move windows but this is probably because are running in RAM etc…and after 20-30 seconds system comes back normally. Also sometimes I notice mouse lags. 

I checked into windows log and I don’t see any error related, I also run Crystaldisk and I don’t see any errors from the disk there(S.M.A.R.T).

Today I was checking the bios and I noticed that SATA setting was in IDE. I changed it to AHCI and things seems to be better. But while running GTA 5 to test the system, At some point game started lagging like seeing a GIF picture. In frames. After 20-30 sec stopped and it was running ok.

Is there any way to do some diagnostics to the disk and check him if he is the problem or not?

The system is brand new. I already checked Memory ( They are also new ), Mobo , and changed SATA cables. The problem appeared after the transition from HDD to SSD.

System Specs are :

AMD 8320 FX

Asrock Extreme 3 Rev 2.0

DDR3 Crucial 12GB 1600Mhz

SSD 480GB Sandisk


ATI Radeon R9 270x

Thank you

Christos P.

AHCI is definitely a better setting so its good that you made that change. 

If the SSD is benchmarking correctly and the SMART is not showing any problems it seems like the SSD is working normally. You could try a secure erase (that should reset the drive to out of the box performance and reinstall to see if there is any improvement. 

The problems you are experiencing sound to me like they could be video card related. I would suggest updating your video drivers and see if there are any changes. 

Well, I don’t think so that it is the graphic card because it is doing it without running a game or something too.

I installed Jdownloader, and I started downloading from Easybytez parts of total 30gb. Since downloading started and data started writing to the disk I instantly noticed Dekstop spikes, mouse lag, and delay in opening files.

 Here is the S.M.A.R.T of my disk during this operation :  I don’t see anything bad but stil… I wonder what is going on it is very frustating :frowning:

HDDScan S.M.A.R.T. Report

Num Attribute Name Value Worst Raw(hex) Threshold

005 Initial Bad Blocks Count 100 100 0000000000-0000 000

009 Power-On Hours Count 034 100 0000000000-0022 000

012 Device Power Cycle Count 100 100 0000000000-000D 000

165 Unknown Attribute 100 100 0000030033-0022 000

166 Unknown Attribute 100 100 0000000000-0000 000

167 Unknown Attribute 100 100 0000000000-0035 000

168 Unknown Attribute 100 100 0000000000-0003 000

169 Unknown Attribute 100 100 0000000000-0000 000

171 Program Fail Count 100 100 0000000000-0000 000

172 Erase Fail Count 100 100 0000000000-0000 000

173 Wear Leveling Count 100 100 0000000000-0001 000

174 Unexpected Power Loss Count 100 100 0000000000-0002 000

187 Reported Uncorrectable Error 100 100 0000000000-0000 000

194 SSD Temperature or Empty 062 042 00002A0019-0026 000

199 SATA R-Errors Count 100 100 0000000000-0000 000

230 Unknown Attribute 100 100 0000100014-0014 000

232 Unknown Attribute 100 100 0000000000-0064 004

233 Unknown Attribute 100 100 0000000000-00B2 000

234 Unknown Attribute 100 100 0000000000-0165 000

241 Total Host Writes 253 253 0000000000-013A 000

242 Total Host Reads 253 253 0000000000-00E5 000

244 Unknown Attribute 000 100 0000000000-0000 000

I see here now Unexpected power loss 2… What is this ? This is SMART from Sandisk SSD Dashboard

Also perfomance is not reaching the promiced one… 500-550mb/sec …instead I am getting top of 405mb/sec . I can confirm that my mobo is SATA3 and it is connected properly.

And Sandisk Dashboard during test :

Benchmark with Crystal Disk Mark and use the default settings. That is what sandisk uses in their test. Also what SATA chipset and driver are you using? Some chipsets even though they are SATA 3 will not reach the full speed. IIRC SanDisk usies an Intel SATA chipset and the Intel SATA RST driver for speed claims. I ahve a MB that has 2 different SATA chipsets and the AS media chipset will not perform and faster than about 400MB/s regardless of what driver I use. The intel chipset on the same MB performs at 500/550 regardless of using the Microsoft or Intel driver. 

I would try a secure erase and reload just to see if the performance will change. This should rule out any file system or installation issues. 

The SMART looks like the hardware is fine. The unexpected power loss will happen anytime the SSD loses power unexpectedly. These can occur from things like an ungraceful shutdown, power dip from the power supply, or any other unexpected power loss. 


I am using a AMD Sata chipset. My motherboard is Asrock 970 Extreme 3 Rev 2.0. Windows 8.1 had the Sata drivers from microsoft outdated since 2006. I installed the latest chipset drivers ( Which ASROCK has not taken care to have them on their website though ) and I saw some speed improvement from 406 reading to 436mb/s. and writing almost 5-10mb/sec more. 

The speed is not so important for me ok there is a big difference but not so much. I am caring more for the spikes/lags which I don’t see any for now ( though GTAV  still continues to lag at some point during gaming and I think specs are over covering the GAME so it’s not the specs ). 

I will monitor this and I will give further updates about this issue.

Summary for users having the same problem :

Update Chipset drivers - BASIC! Do not leave Microsoft Drivers inside are outdated and not proper for latest SSD Drives

Change SATA Cable - It happens many times a defect cable to create spikes/lags/disconnections

Put AHCI in BIOS - It is the proper mode for SSD’s

Best Regards,


Just saying, maybe ur other HDD is lagging and windows waits till HDD responds. I heavily doubt is the SSD.

Test the SSD whidout the HDD and make shure the SATA cables are ok.

I have a 960GB drive that has partitions on it.  I tried to remove them so that I can clone my hard drive using Acronis 2016, but it has two partitions on it.  But I don’t have access to remove them.  What do I do to setup the ssd to clone my hard drive?

@rcsmg wrote:

I have a 960GB drive that has partitions on it.  I tried to remove them so that I can clone my hard drive using Acronis 2016, but it has two partitions on it.  But I don’t have access to remove them.  What do I do to setup the ssd to clone my hard drive?

you have now posted in 2 threads that dont have anything to do with your question. You probably should start a new thread of your own. 

So far I have not seen what you have posted, but I can tell you that my 1.5 year old Samsung 840 Drive, (when new was 200+ R/W), is now 100+ R/W  while   my Sandisk Ultra II remains 250+ R/W, and both reside on the same system…  Supermicro Server, SATA II, W7-64 here.

All SSD’s here have current firmware…