Solved: Sansa e250 / Media Converter 2

Gee, it took me hours (literally) to get a hold on this.

My sun owns a Sansa e250 - not Rhapsody - model, and I’ve downloaded the Sansa Media Converter 2 yesterday to download YouTube videos he wanted on the player. Same history as many posts I’ve found here: it wouldn’t convert, or show two devices (the player and a MicroSD card - which he doesn’t have - on the “Information” screen, no recognition of the MP4 files if transferred directly to the player etc.

Obviously I can’t guarantee this solution will work for everyone, but to me what worked was:

  1. I’ve closed the Media Converter,
  2. Copied all songs on the player to the PC (regular Windows Explorer’s copy functions),
  3. While on USB MSC mode, formatted the player (regular Windows Explorer’s “format” command),
  4. Changed the USB mode to MTP.

That’s it. From this point on, the Media Converter would show only the player - and no longer a non-existing MicroSD card - and the MP4 files I’ve previously created could be added and converted.

If I try to copy an MP4 file directly to the player it won’t allow it, saying the file won’t be recognized.

Also, while on USB MSC mode two drives were shown on Explorer - one called “Sansa E250” for the player, and a second one for the MicroSD slot. On USB MTP mode, there’s only a single “device” called “Sansa e250”, which has a drive icon called “PPI NAND” and the regular folders (Music, Photo etc.) below it; as I don’t have a MicroSD card, I can’t say how this would work with one in place.

While my sun is happy with it, I must say SanDisk made a hell of a player and really should pay a ***lot*** more attention to so many users complaining about something that should be really simple to accomplish. Shame on them for not doing it.

Hope this helps someone!

Message Edited by danielmendes on 03-09-2008 01:49 AM

ok ill try that

ive been trying to find out how to fix it for 3 months strait right now so if just in case it doesnt work can anyone please please please!! tell me how to fix this if you know!

thanks   :wink: