Scheduled TRIM command incorrect.


I’m using Dashboard version On the Performance menu, under TRIM, the Windows Task Scheduler button creates the TRIM task in the scheduler correctly; but with the wrong command.

The command that configures the task to carry out is

%WINDIR%/System32/Defrag.exe C: -0 -H

But there’s no “0” (zero) parameter to pass to defrag.exe! The correct one is “O”. It should be an easy fix.




1 Like

I will make sure someone looks  into this.  SanDisk users are the BEST! Thank you.


I purchased a refurb Dell PC with SanDisk X110 SSD on it. After doing some research, I discovered and installed SanDisk SSD Dashboard version My operating system is Windows 7 Pro. 

I want to add to OP’s post regarding the scheduled TRIM command. In version, the command has been corrected from -0 to -O. However, defrag.exe for Windows 7 does not have -O (for Optimize) option.

I tried running the scheduled task manually, and altough Windows Task Scheduler says it completed succesfully, if you look carefully to the command prompt screen, you’ll notice how defrag.exe printed out the help page.

When I ran the command manually in command prompt, I received the following message:

The parameter is incorrect. (0x80070057)

I think the application should be updated so that it won’t offer the option to install automatic TRIM scheduled task for OSes lower than Windows 10. I’m not sure whether Windows 8/8.1 has the Optimize option for its Defrag.exe.