Sansa Fuze files problem

Sansa Fuze silver 8GB, about half full, all with music (mostly mp3s, a few wma’s). Today I put a new playlist on my Fuze, and one replacement file for one file that was just inferior on another album (I have everything arranged by album). When I finally get around to listening to the playlist, nothing is playing. When I hit the skip button, the player froze. I reset it, and the player’s already on the second track, which also isn’t playing. Repeat once more, with the third track. Obviously I wasn’t going to be listening to that album, so I went to another album - the one with the replaced file. Once I get to said file, it plays for 11 seconds, then stops working, and I have the same problem as with the other playlist, except I know the rest of the files on this album are functional because they’ve been there for a while and I’ve listened to them countless times.

I delete the playlist, and the album the single rogue file was on (for shortness sake I’ll just call it Master Of Puppets from here on). I do that without issue, but I try to restore Master Of Puppets to the Fuze. No luck. I’m syncing using Windows Media Player, by the way. Never been a problem for me before. I’ve tried about 4 times, and the same result - the first file gets to 100% synced, and then it does nothing. The program doesn’t freeze, the sync just stops (not officially, it still says its syncing, until I stop it myself).

Then, as a bonus, I check back into the files on my Fuze (disconnecting and manually looking around), and I find that the playlist I had deleted (not MoP) is still there, and when I click on it, the first three tracks… the ones I had attempted to play… are all replaced by the title of the single rogue file, and still don’t play.

So, um… resolutions plz?? :confused:

Well I got it to sync (Master Of Puppets). Apparently after I got rid of that other playlist where MoP files kept replacing everything, there will still tons more stray MoP files that weren’t turning up when I went through the albums that I had to delete. Might explain the sync troubles, since the computer already detected the same file on the Fuze in a different place.

Still, can anyone tell me for sure what might have happened so I don’t do this again?

So this is happening again. Only now random files - most of them being ones I added today - are disappearing, as opposed to just replacing other files. Same sync issue, WMP11, first file on the sync list gets to 100% and freezes there (after the ‘preparing to sync’ message takes a small eternity). Every time I try to access the Fuze manually (My Computer), I keep getting the ‘this device is busy and may not show all contents’ pop-up - even after closing WMP. Every time I disconnect the Fuze, it says ‘refreshing media…’, even though I haven’t changed anything. Actually it whitescreened me once, too. Now I’ve discovered two blank files that keeping coming back on the Fuze after numerous manual deletes (they return after I either the turn system off and back on, or unplug it from the computer), and I’m pretty sure these are the issue. All my stuff is arranged by album, that’s how I access it during use, and these are simply showing up under ‘Unknown’. The two track titles are the same as the normal ones. The tracks won’t play, they just sit there. Ghost files, I guess. This is quick, hasty, uber-frustrated write-up, let me know if you need me to clarify something further. Solutions/ideas would very much appreciated.

EDIT: All this was done in MTP mode. I read another thread that suggested changing to MSC mode and deleting the mtable.sys fiile. Did that, no luck, still having the same problems. And the ghost files keep coming back.

EDIT: Now the album that these two ‘unknown’ files were intended to be on is not showing up in actual Fuze use (the Unknown files still show up under that entry), but when its connected and I view it on the computer the artist and album are constantly reappearing (I’ve tried deleting this as well; its the only album by this band I have on here right now), but its only in computer mode that I’m seeing the album.

Message Edited by masterofpuppets on 11-26-2009 09:28 PM

Message Edited by masterofpuppets on 11-26-2009 09:34 PM

Message Edited by masterofpuppets on 11-26-2009 09:55 PM

Is there some reason you are using MTP mode? Are these files from a music service (Rhapsody, Napster) with DRM? Because otherwise you are going through totally unnecessary stuff.

Unknown means the tags are in a format the Sansa can’t read. Your computer can read lots of formats, but Sansa like ID3v2.3 ISO–8859-1. ID3v1 will show up Unknown. 

Delete the bad files and albums from the unit. 

Switch to MSC mode.

Rip the album to .mp3 and save it on your computer somewhere. (You can do that with Windows Media Player, iTunes, foobar, lots of other players). 

Download mp3tag. 

http://www.mp3tag.de/en/

When you install it, let it add itself to context menus. Open mp3tag and set Tools/Options/Tags/Mpeg to Write ID3v2.3 ISO-8859-1. Save that so it becomes the default. 

Go to the folder of the album you ripped.

Right-click and let mp3tag open it. 

Highlight all the files. Make sure they’re in the order you want them to play. Under Tools/Autonumbering Track Wizard choose the Leading Zeroes option.  Run the wizard. That gives you good track numbers and ID2v2.3 ISO-8859-1 tags.

Your life burns faster.