Sansa Clip+ Firmware Update 01.02.18

I did updating of my Sansa Clip + for version 01.02.18, but I’m having some problems: It restarts when it’s playing FLAC files.

1 Like

Wow !

Finally !!!

I was having nightmare because of this “freaky frozen thing” with my clip+ !!!

I did everything, format, reformat, I even got some software to remove ID TAG from mp3, 

anyhow !!! This is the best !!! No problem anymore !

worked for me !

@arjang wrote:

Wow !

Finally !!!

anyhow !!! This is the best !!! No problem anymore !

 

worked for me !

 

 

“What” worked for you??? :confounded:

I have so many mp3s which I couldnt play because It was cause of freezing/hanging the sandisk !

now I tested all of them and Im happy !

what was your problem ?

Mine is still hanging on some MP3s after this upgrade :frowning: 4GB, 32 GB external microSD)

@henrikar wrote:

Mine is still hanging on some MP3s after this upgrade :frowning: 4GB, 32 GB external microSD)

Answered in your duplicate post:

http://forums.sandisk.com/t5/Sansa-Clip-Sansa-Clip/MP3s-no-longer-play-from-external-microSD-after-upgrading-to/m-p/285140#M42537

@dandan_1976 - I have exactly the same issue with player freezing and resetting when locked. I have discovered that this happens if the following conditions are met:

-          music files are played regardless of format (does not happen when playing FM radio)

-          backlight time is set to 5 or 10 seconds.

I am currently bypassing the problem by setting backlight to 15 seconds. Check if it works for you.

Sandisk support offered me to exchange the player but as the procedure takes a few weeks I learned to live with it.

The Sandisk Updater haven’t worked for me with my Clip+ players at all. I get an installation failed everytime, running win 7. I guess im not alone?

@djchristian wrote:

The Sandisk Updater haven’t worked for me with my Clip+ players at all. I get an installation failed everytime, running win 7. I guess im not alone?

 

Why not just update manually? It will take less time than installing the Updater and waiting for it to perform the update.

After update firmware from 01.02.16f to 01.02.18 my PC not reconize player and show the message “one of yours devices have failure but system not rconize it”. WTF? My system is WinXP (before update everything was OK).

@robert_pl wrote:

After update firmware from 01.02.16f to 01.02.18 my PC not reconize player and show the message “one of yours devices have failure but system not rconize it”. WTF? My system is WinXP (before update everything was OK).

Updating the firmware will revert the player back to the default Auto Defect USB connection mode. Chances are, you had it in MSC mode before which is why it worked. Try going into Settings > System Settings > USB Mode and changing it to MSC.

Tapeworm Thanks! for advice. It`s works for me but with one exception: I must switch off player after change USB mode (without this i still got error message).

Hi guys…

I just want to inform that, by my recent experience, this new firmware has som problems playing .FLAC files, which the .15 and .16 didn’t.

When I just received my Sansa Clip+ I ripped one of my cds and put it in… all perfect. It came with the 01.02.15 firmware, and then, the same day I updated the 01.02.18 firmware manually. All i listen is FLAC, so I continue to rip my cds using EAC for perfect tagging. Suddenly the sansa got frozen at track 5 on one of the albums, and after experimenting with different rip methods just the untagged rips were rid of this problem. Some more albums with all their tags continued to frozen at track 5 or 6, always those at those numbers.

Yesterday, tired of it, I downgraded the Sansa to 01.02.15, and then listen to a copule of those same troubled albums and NO FROZEN SANSA… it flowed perfectly. I originally thought It was the USB MODE, but no. It was the  01.02.18 firmware  itself. It has problems with FLAC files on tagged albums or something. The funny thing is that the problem is either with track 5 or 6 at first, not before them, at least with me. When one of those tracks ends, the Sansa player freezes or reboot itself.

I re upgraded the unit to  01.02.18 firmware  and presented the probem again, then I downgraded to  01.02.15  again and no problem, then upgraded to  01.02.16 and  no problem. I let my sansa in the .16 firmware from now on.

One thing got my attention: with the . 15  and . 16  firmwares, the sansa does not freez, but there is one “click” sound at the end of either one of those same “troubled” tracks (5 and 6 track of the albums) that caused the sansa to frozen on the  01.02.18 firmware. 

 

PD:  there has been some other reported problems about this issue. Here es one from a couple of months:

Clip+ update 10218 problem with .flac files ?

jpar

08-17-2012 08:19 AM

Hello,

I have updated to .18 from .16. Since I have had  problems with some .flac files. The clip freezes and I have to restart again.I have returned to .16 and everything seems all right

 

Although I don’t fo FLAC, thanks for posting this advice.

Although I don’t do FLAC, thanks for posting this advice.

Well… I uploaded the tracks that caused my sansa to froze. As you can see I’m a big film music fan hehe…

hope someone find it useful…

http://www.mediafire.com/?7222zaab84ajy5a

Maybe It’s just me but after manually installing this firmware the transfer rate became very slow, more than 10 times slower than before: around 150-200KB/s (memory mass mode)

I have followed the instructions, but when I remove the Clip+ from the computer, the update does not start.

@greg_brown wrote:

I have followed the instructions, but when I remove the Clip+ from the computer, the update does not start.

Did you make sure to “extract” the downloaded .zip file? The file after extraction should have a .bin extenision. This is what you drop in the root directory on the player.

After unplugging from your computer, the unit might shut off. When you press the power button again to restart it, it will perform the f/w update.

hi, i recently tried using Rockbox but didnt like it so i tried switching back to the original firmware. i downloaded the latest version, formatted my player and tried installing it manually following the instructions. when i disconnect however it is saying file not found and plug usb cable. when i connect the player it the says Bootloader USB mode. can anyone help please? EDITED to say i did extract the file and it does read.bin