Sansa Clip E46K mp3 player is dying, please help!

I own a Sansa Clip SDMX18 008G E46K. Yeah, I know it’s old, but it’s served me well… until now. A while ago I started having issues where it would sometimes pause itself when I tried to skip backwards a few tracks and the only way to unpause would be to reset it. Now today I’ve tried to add some new mp3 files and it’s just not happening.

If I try dragging and dropping, I get the usual “copying” window and the progress bar fills just a little bit then disappears with a chime as if there’s an error, but I get no pop up message. If I try moving from the original folder into my SanDisk folder, I just get a message that says the folder cannot be used. The mp3 player screen says it’s definitely connected.

Please help. I have thousands of tracks on there and the prospect of having to buy a new player and move them all over or worse - download them again if they’re corrupted - is terrifying.

P.S. It’s probably one of the first questions I’ll be asked, so to pre-emp it; my internal memory has 1.13gb free of 7.36gb.

Hi @Chris1982,

Please contact the SD Technical Support team for best assistance and troubleshooting: