Sansa C250 won't sort by id3 tags

Hello, Everyone
I just purchased a new Sansa C250 and it seems to work just fine, except for one problem that might make me return it to the store if I can’t find a workaround.
Right off the bat, I do not use Windows, and I will not be using Windows with this player.  I use a version of Linux called Fedora Core 6.  Here is a numeric list of what works so far:

  1. Plug the player (using the provided USB cable) into my Fedora computer.  The result is that the player is automatically detected, and I am asked what I want to do with it.
  2. I choose to open the player in a new window.  I click “Ok” and a file manager window is opened right to the MP3 player’s directory.
  3. I then drag and drop the files I want to the “MUSIC” directory.  This works as expected.
  4. Unplug the player from the computer, and the Database refreshes.  No problems at all so far…

But, when I select the “Music” menu and choose “Artists” or “Albums”, all I see is “Unknown Artist” and “Unknown Album”  I know for a fact that the id3 tags are their, because I can browse to the C250’s mount point and view the tags in a file manager.  Here is a screenshot to prove it:
http://www.afolkey2.net/~steve/SanDisk-c250-ScreenShot-001.jpg

Just in case, I dropped all the mp3’s in MUSIC directory itself.  I tried it in separate directores at first, but that does not appear to make any difference.

So where things stand is that the id3 tags appear to be stored on the MP3 player itself in one way or another.  Otherwise I wouldn’t see them when I view the files in a file manager.

So any help you can give me is greatly appreciated.

Steven P. Ulrick

Hello again
I have done some further experimentation, and I still have not had any acceptable success.  I discovered that if I remove all id3 tags from mp3’s that I want to put on my Sandisk Sansa c250 and retag just the Album Title and the Artist, that the c250 will sort by Album title and Artist.  BUT, the songs are listed in random order.  For example, I retagged an album called “Dancing In Jerusalem” by an artist called “Lamb” using the following command:
id3tag -2 --album=“Dancing In Jerusalem” --artist=“Lamb” *.mp3

The result is that “Dancing In Jerusalem” shows up in the Albums menu as “Dancing In Jerusalem.”  This is correct.  Also, “Lamb” shows up under the Artist menu, and “Dancing In Jerusalem” shows up inside of the “Lamb” menu.  BUT, the songs display in random order.  I tried to add the track numbers with commands like this one:
id3tag --track=1 01\ -\ Dancing\ In\ Jerusalem\ -\ Lamb.mp3

The track numbers were added just fine.  But, the files still display in random order.

I will probably return this unit if there is no fix to this problem, but I will continue to inform you of any further experiments that I try.

Like I mentioned in my initial post on this thread, I do not use Windows here at home, and I will not use it just to use this mp3 player.  If this actually does turn out to be a problem for me because I don’t use Windows, that is still not a good reason for me to be having this problem.  My humble opinion is that (within reason, and with certain qualifications) an id3 tag is an id3 tag, and the OS that is being used when the tags are written should make no difference at all.  Having to use id3v2 instead of id3v1 is reasonable.  id3v2 tags from Windows working with this unit, but not id3v2 tags applied in Linux is not reasonable.

Anyway, thanks in advance for any light that you can shed on this for me.
Steven P. Ulrick

I get results similiar to yours using XP pro. Is the sort truly random? I think it sorts by alphabetic order. I added a playlist for each album and I access the albums via the playlist rather than the album. I think that you could rename the title to be “01 - Dancing in Jerusalem” so that the track number is actually in the title tag. Note that if you have both v1 and v2 tags, the c250 will respect the v2 tag and ignore the v1 tag. If a utility is displaying v1 tags you can get confused.

The first thing I did when I began seeing these issues was to remove both v1 and v2 tags.  I then proceeded to retag ONLY the Artist and Album fields using a command like the following:
id3tag -2 --album=“Dancing In Jerusalem” --artist=“Lamb” *.mp3

One thing I did not mention in the initial posting that I referred to that command in was that the “-2” flag tells the “id3tag” command to only write v2 tags.

As far as being truly random or not, I will now turn on the player and type the exact order:
09 - You Are There - Lamb.mp3
01 - Dancing In Jerusalem - Lamb.mp3
06 - Enter His Gates - Lamb.mp3
07 - The Set Time Has Come - Lamb.mp3
08 - There Is A City - Lamb.mp3
03 - Latter Rain - Lamb.mp3
02 - It Is He (Bonay Y’rushalayim) - Lamb.mp3
10 - Holy, Holy - Lamb.mp3
05 - All You’ve Done For Me - Lamb.mp3
04 - You Are My Salvation - Lamb.mp3

As you can see, there is no APPARENT order here.

From my previous posting on this subject, I see a mistake that I made regarding the following command:
“id3tag --track=1 01\ -\ Dancing\ In\ Jerusalem\ -\ Lamb.mp3” should actually have been this:
“id3tag -2 --track=1 01\ -\ Dancing\ In\ Jerusalem\ -\ Lamb.mp3”

I will retag the above referenced mp3’s to see what happens when I use the correct syntax:
Now the mp3’s sort perfectly.  So, I can theoretically make this player work for me.  Of course I would have to do the following for every mp3 that I ever put on this player:

  1. Copy them to a temporary directory on one of my harddrives.
  2. Remove all the tags.
  3. Add the Album, Artist and track number tags using a command line program called id3tag.  Here lies the problem.

If I went through adding the track numbers using id3tag, I would have to make shell script that looks like this everytime I add something to my player:
id3tag -2 --track=1 01\ -\ Dancing\ In\ Jerusalem\ -\ Lamb.mp3 &&
id3tag -2 --track=2 02\ -\ It\ Is\ He\ (Bonay\ Y’rushalayim)\ -\ Lamb.mp3 &&
id3tag -2 --track=3 03\ -\ Latter\ Rain\ -\ Lamb.mp3 &&
id3tag -2 --track=4 04\ -\ You\ Are\ My\ Salvation\ -\ Lamb.mp3 &&
id3tag -2 --track=5 05\ -\ All\ You’ve\ Done\ For\ Me\ -\ Lamb.mp3 &&
id3tag -2 --track=6 06\ -\ Enter\ His\ Gates\ -\ Lamb.mp3 &&
id3tag -2 --track=7 07\ -\ The\ Set\ Time\ Has\ Come\ -\ Lamb.mp3 &&
id3tag -2 --track=8 08\ -\ There\ Is\ A\ City\ -\ Lamb.mp3 &&
id3tag -2 --track=9 09\ -\ You\ Are\ There\ -\ Lamb.mp3 &&
id3tag -2 --track=10 10\ -\ Holy,\ Holy\ -\ Lamb.mp3

I had had the New Testament of the Bible on this mp3 player.  260 mp3’s.  Simply not worth it to me :frowning:

So, if there is  a workaround to this, I will be able to keep this player.  If not, I will return it to Staples, if they will take it (I only bought it a few days ago, and I do have the receipt…)

Before I close, I just thought of one thing: I would be glad to update the firmware to see if this issue has been fixed.  Unfortunately, the Firmware Updater is an exe file, so I can’t run it on Linux…  IF I am inclined to do so this weekend, I will go to a Windows machine I have access to and try updating the firmware.  If not, back to Staples to get a refund.  Yes, I know that the package said that only Windows was supported.  But the U.S. Robotics modem that I used to use on my Linux computer only supported Windows.  But, it “Just Worked.”  It seems to me that someone should be able to design an mp3 player that does not exclude people who chose to not use any Microsoft products.

Thank you very much for your response to my problem, and as long as I have this player, I will try anything else that you suggest.

I have a similar problem as you, except that I am using Windows XP. However, I think I can offer a guess to one of your questions… the order that you upload your song files to the device is probably the order that they play on you use the “play all” option. I haven’t tested out this theory on my C200, but other mp3 playing devices I’ve experienced work this way.

I am uploading mp3s and wmas to my C200 by dragging and dropping them into the Music directory on the C200. The songs show up and play just fine, but a few random songs will not show the ID3 song title info. The C200 appears to be reading the artist and the album, but not the song title. I tried editing the ID3 info on winamp and updating, but it made no change. So next I tried deleting the song from the C200, editing the ID3 info on my computer with winamp, and then uploading it again. This made the changes to the artist and album show up, but song title still is not being read. Actually, after editing the ID3 info with winamp on a song which was showing its song info correctly, the song title stopped working. This overall problem seems to affect mp3s and wmas alike. I do not see any pattern in the song files for which the C200 does not read the ID3 song title; it appears to choose them at random.