Sansa 8G clip stuck on "connected".


My new Sansa 8G clip is giving me some serious headaches tonight.  Until now, it’s ben all good, but now it first got stuck saying it was ‘writing’ and would not let me put anything on.  I checked out some answers regarding that problem, disconnected the Sandisk, turned it off (held the power slide up for abot 20 seconds, just to be sure) , turned my computer off then back on - no help there. 

I then tried using the ‘Safely Remove Hardware’ icon on my desktop, but the Sandisk still said ‘connected’.  Again I removed it from the USB link with the computer (and I have tried 2 different cables), turned it off & back on following the same procedure as before (after it got done 'refreshing files) and now it still says 'connected, with arrows running back & forth on its screen from its icon to the computer’s, and still won’t let me do anything.

Also, somewhere early on, I downloaded the lateest firmware update.  Where do I go from here?

Thanks to anyone who can help!


I don’t know what I did or how, but the problem is now fixed.

Thanks anyway,