SanDisk Ultra USB 3.0 Flash Drive

Just received this drive.  Plugged it in to USB 3.0 port. Drive inserts and reinserts constantly.

Put drive in USB 2.0 port and drive is ok.

Drive is supposed to be USB 3.0 but doesn’t work in USB 3.0 port.

Can you try the flash drive in a different pc?

Looks like my USB 3.0 hub is failing.  Thanks

Maybe some of the other devices plugged into the hub are impacting the flash drive.

I will leave this marked as solved for now, but I’m not 100% sure the USB 3.0 Controller is failing.

I can use other USB 3.0 flash drives in the same ports and they work perfectly.  I can also use external

drives in the same port with no issues.

I am however, going to replace the existing USB 3.0 controller with a new one to see what happens.

I’ll report back when I’ve replaced the controller.

OK, I can finally update this thread.

I just replaced my USB 3.0 Controller card.

I can now insert the flash drive and it is seen correctly.

I have never had more than 1 device plugged into the controller at a time, so that is not an issue.

My old controller card was 5 years old or older with no updates.

I’m assuming at this p oint that the old controller was unable to handle newer UCB 3.0 devices


I have some more testing to do, but at this point I think the new controller has solved the issue.

I will consider this issue to be resolved.

Thanks for all the input.

Thanks for the update.  Always like threads with happy endings.  :smiley:

And I agree with your assumption.