SanDisk Ultra 128GB paritioned by an installation process, at the end could not access full capacity, only 119GB!

Hi,

I have been trying to fix my issue using a few methods of putting 2 paritions together on my micro SD card that was created by an installation programme automatically. It made part of the capacity unallocated somehow, and only 119GB was shoiwn as healthy in Disk Management. I searched on the Internet on how to put the partitions together, but I struggled. I had tried formatting the partitions into exFat and NTFS. I had tried full formatting a few times, which took a very long time. I tried deleting a volume to make it unallocated, which was fine the first time. I think when I deleted the smaller partition that was unllocated, it was when the whole partition completely went!!! This was a mistake I made I think. Then, I tried using cmd command to fix the issue. In Command Prompt, I have tried “list disk”. My micro SD shows as 119GB, and a smaller capacity also available. Following the instruction of some Internet advice, I have tried "select ", and then “delete partition”, then “format”. The formatting took ages like a full format in Disk Management. At the end, I still only have 119GB available. Lots of people commented this work for them, but mine still doesn’t work. I think what went wrong was when I was in Disk Management, I deleted the volume for the unallocated parition. Will I ever be able to get the full capacity of my micro SD card back? :slightly_frowning_face:

Can anyone help in here? Any advice please?

Thanks.

Hi @lingglingg,

We understand that the capacity of your memory card appears to be smaller than you expected.

What you are observing is the difference in the definition of one Gigabyte by operating systems versus product manufacturers. Operating systems use a binary system which will present a lower number of GB than the decimal based system used by manufacturers to define the capacity of products. This is due to the binary system representing a GB as a higher number of actual bytes.

For example: Operating systems define a 1GB as 1,073,741,824 Bytes. We define 1GB as 1,000,000,000 bytes.

To understand this difference in definition better, you may refer to the following articles from our online Knowledge base:

https://kb.sandisk.com/app/answers/detail/a_id/46

Hope it helps!!

Thanks for your response.

When I took the card out of the box, the computer says it was 127GB available to use, but now it’s 119GB after installation process and then I did delete a volume it’s was only 16MB or so. After deleting, I cannot see that volume anymore.

My computer says only 119GB available, so where’s that 9GB has gone??!

Hi @lingglingg,

This is to inform you that for 128GB you will get capacity between 115GB to 119GB as per OS Calculation.

To understand this difference in definition better, you may refer to the following articles from our online Knowledge base:
https://kb.sandisk.com/app/answers/detail/a_id/46

Please refer link for any information : https://kb.sandisk.com/app/ask/

OK, before formatting my sd card, out of the brand new packaging, my computer says 127GB usable.

Why does formatting make the capacity less?? Where has it gone?

You can use the SD card Association formatting utility SD Memory Card Formatter for Windows Download | SD Association

Card size = 128,000,000,000 bytes = 119 GB

The capacity does not disappear, it is right there.