PRO-Blade Transport and Mac Network

Is anyone here using the PRO-Blade Transport on an Ethernet network with a USB C adapter?

I tried connecting it to my LAN using a powered Ethernet to USB C adapter and couldn’t see it on the network. I tried several adapters, cables, and Ethernet ports with no success.

Also, when I connect it directly to my MacBook Air via USB C I can see the drive, but can’t write to it.

I opened a ticket with Western Digital and this is what they said about the first issue:

"Unfortunately, we have not tested the PRO-Blade Transport drive through an Ethernet to USB-C adapter. As a result, it may not show up under the network. We realize this may not be the news you were hoping for, and we apologize for any inconvenience this may have caused.

While we cannot guarantee that the drive will work with an adapter, we always suggest connecting it directly through the USB C cable. This will ensure the best possible performance and compatibility with your devices."

They have not yet responded to the second issue.

Hi @Radock,

Have you opened a Support Case? If not opened, for more information, please contact the SD Technical Support team for best assistance and troubleshooting: