Possibly dead fuse!

Yesterday my Fuse would not power up.  Its still not working today… It worked Ok yesterday afternoon, but when I went to power up at night - nothing.   I have tried holding the power switch in the on position for the usuall 15 of so seconds - five or six times - and unfortunately this has not helped.  I get no response from the computer when I connect via the USB cord {I have checked the cord with my e200 sansa - and its Ok}; similarly I get nothing when I plug it into my sansa dock.  Only suggestions I can find on the forum appear to relate to soft reset.  Has anyone any other suggestions that might help?


How long did you leave it connected to the PC? If the battery is extremely low, it may need to charge for a while before it even has enough power to turn on or respond to the computer.

Hello Professor qwk.  The battery on the Fuse was well over 50% when I turning it off in the afternoon so it should not be a battery problem.  But, in case I made a mistake and did not turn it off correctly (though at the time I tried to turned it back on there should still have been plenty of power given the charge level), and in consideration of your comments - thank you for these - I put the Fuse in its dock all night, so it has now been connected for many hours.  Unfortunately this has made no difference.  Your solution, although a good suggestion, does not appear therefore to be a solution to this problem…  It seems unlikely to be the switch - if this had gone wrong you would assume that the Fuse would still be recognised by the computer; if it was a faulty computer connection, then you would think it would still switch on - it had enough charge.  Looks like I’m going to have to find the guarantee papers…  Unless anyone else has any additional solutions!  :cry:

Message Edited by Shimbo on 06-21-2009 10:20 AM

Sounds like it’s time for a call to SanDisk Tech Support and an RMA# (Returned Merchandise Authorization). :cry:

Before calling Sansa, there’s one thing I can think of to do – a soft reset (basically, it resets the RAM, but all your files and data remain in tact). Depending on who you talk to, doing a soft reset will be holding te power button in the ON position for ten seconds to a minute.

Reset time will vary depending upon the nature of the error.  If you have sensitive headphones on, you will hear a soft “click” as the Sansa resets.


Thank you all - interesting note on the soft click but unfortunately there is none - even after a very long wait…  Seems its time to call SanDisk Tech Support - thanks again.