new "recertified" Clip won't charge

In my quest to buy all my friends clips, I’ve finally gotten one that is giving me trouble. It is a recertified 1GB Clip from It would not turn on at all and when I plug it in to the usb port, it lights up and does the screen saver, but the battery icon is empty and doesn’t do the charging animation. If I unplug it, it turns off. Tried resetting it. Nada. Had it plugged in for over an hour and doesn’t seem to have any charge yet. Does it have to get to a certain point before the battery charging animation kicks in?

Either this is the notorious “battery wire come off” issue, or the battery got deep discharged at some point. I don’t think lithium batteries can recover from a deep discharge.

In either case you wouldn’t get around opening the Clip to fix the problem (which is not entirely for the faint of heart). No idea whether it’s possibly to obtain a replacement battery at some electronics supplier.

Good news. Sort of. I tried it on a few computers til I got to one where the battery animation worked and left it on there for an hour. This charged it enough to where it now charges on all my computers. It is still charging after 3 hours plus. I was able to get it to turn on long enough to set it to msc and now the computer recognizes it as a drive. later I flashed the newest firmware. So all seems OK. Must’ve been a deep discharge.

BTW, this is my first ver 1 clip, all the others ver 2. It seems that the newest firmware for ver 2 is three times the size of ver 1, yet I’ve read that they perform identically. How can this be?