My MacBook Pro Version 10.10.5 cannot detect iXpand flash drive, when previously it could.

Previously, my macbook could detect my flash drive but a few days ago it could not detect.  However, a few hours ago, when I plugged it in, it was detected.  I don’t have any problem with plugging it into my iphone and ipad.  On both devices, it work perfectly well. I had tried with other usb drives and they work fine too.  Don’t know what’s the problem. Please help!

is the drive detectable on the computer consistently now? 

I’m having the same problem with the Macbook Air 2015.  Last week it was working, and this weekend, after the software update, my Macbook Air won’t detect the drive anymore.  Did an SMC and PRM reset and that doesn’t work.  The drive can be seen on a Windows 7 machine, but only under the Storage Management util, not under the Windows Explorer.  On the Macbook Air, you can see it plugged into the one of the USB3 ports under System Info, but it doesn’t showup in the Disk Utility tool.

I have this exact problem too.

Contact sandisk support it sounds like the drive will need to be replaced. 

I contacted Sandisk and they have agreed, and I have provided them with the information to replace the disk.

But what I don’t know is if the replacement will have the new firmware installed? If not, then the same problem will recur. Do you know?

Unable to get any information regarding the firmware status of the replacement drive, and since I have been asked to return the faulty good by overseas registered mail (apparently at my own expense) I chose to return the drive to the retailer. I won’t be buying again until Sandisk get their act together.

I had this problem, but a  very recent article on had a fix for the USB port that solved it. Apparently after an OSX update, sometimes the USB port become flakey. Doing an SMC reset somehow fixes the USB port to normal. I have pretty sure that it was a software problem, rather than a failed Ixpand drive. In my experience with Sandisk products, I have not seen one hardware failure.

Reference: Mac USB Ports Stopped Working? It’s Likely Easy to Fix;