Macbook Pro Link Speed 1.5G instead 3G

OCZ fixed it way back in October 19, 2011 with thier 2.15 firmware update.

It seems it’s a link speed negotiating issue. For customers with this Nvidia issue, can Sandisk provide a tool to both lock the drive to SATA II (which prevents the fallback to 1.5 issue), or unlock it to negotiate to SATA III?

This would prevent the fallback to 1.5 issue, and allow a customer to later move the drive to a newer Mac.

There is precedent for this; another vendor provided a a bootable tool to do this, back in February.

+1 to ono’s request.  We are still awaiting a solution since March.

Hello!

Well surprise surprise! I got the exact same problem with my brand new Sandisk 240GB installed in my late 2009 MacBookPro running Lion latest update. While I understand it cannot run SATA 3 it does not even run SATA 2 as it should but SATA 1. Deceitful specification and business much?!

I demand a fix ASAP and so should you!

By the way Newegg reviews are starting to pop up pointing out this exact same issue.

Since there has been no communication from SanDisk, I’m returning the drive to Amazon. I’ll be getting another Vertex 3, and 257MBs read speed.

@ono wrote:

Since there has been no communication from SanDisk, I’m returning the drive to Amazon. I’ll be getting another Vertex 3, and 257MBs read speed.

I wish i could do the same :frowning:

I am returning mine too, seems like sandisk doesn’t do anything. ocz solved the problem.

I just installed my Sandisk 480GB R201 drive into my Macbook Pro from 2009 (Macbook5,5) and I’m not seeing the problem.

I see

NVidia MCP79 AHCI:

Link Speed: 3 Gigabit

Negotiated Link Speed: 3 Gigabit

I have yet to see the negotiated link speed go to 1.5 Gigabit.

I also have the latest EFI update (MBP55.00AC.B03)

Which version of osx are you using?

If i’m not wrong, you’ll probably see a lower negotiated speed after a reboot. I don’t remember exactly if it happens when you simply reboot, or if you have to turn off and then turn on you Mac. 

I am running OS X Mountain Lion

I queried the report below after several soft reboots between OS X and Windows.

same problem here with nvidia controller link speed… just want to add my request to this forum to have sandisk resolve this issue for better speed results. right now with extreme 240gb in my 2008 macbook pro sees 108MB/s write and 134MB/s read according to blackmagic test results. everything was updated to latest version including efi.

snow leopard 10.6.8

Hi, I have encountered the same problem. Hope to have a solution soon :frowning:

I have the same problem. I’m really sad and mad with this. If the OCZ has the same problem and solve it why sandisk doesn’t spents some time to solve this? If the sandisk doesn’t solve that i will return my disk.

Hi DrLucky,

Has there been any progress made by your engineering team?  I am ready to re-open my trouble ticket in an attempt to escalate this issue.  Regular status updates would be much appreciated.

SanDisk support has said updates would be posted to this forum first. Since nothing has been posted no update is availble. 

That is really unforunate and dissappointing.  Can you please let them know that many of us are still awaiting a solution.  At least a progress report would be encouraging.  

Does SanDisk engineering anticipate releasing a fix to lock it into SATA II mode?

Knowing whether the issue is on their list to fix and actively worked on, or not not to be fixed, would help. 

Thanks.

Count me in.

I have also the NVidia MCP79 controller and an Sandisk Extreme 240 GB ( SanDisk SDSSDX240GG25 ).

Aso ne negotiated link speed locks at 1.5GBit/s.

This is a big issue for me too.

It doesn’t seem anybody from Samsung reads this forum. I submitted a support question, here: http://kb.sandisk.com/app/ask/

  #120810-00####

A member of our support team will get back to you soon.

That would be SanDisk support and engineering doesn’t seem to read this forum.