Ixpand not detected

I bought a 64Gb Ixpand for my daughter and it didn’t work. Everytime I plug it into the Iphone (6 PLUS OS 10.3.3) it gives a message “Ixpand would like to communicate with the sandisk ixpand flash drive”. When I select “Allow”, it opens the app and gives this error message “Failed to connect to ixpand drive.  Please remove and reattach.”. I do it but it doesn’t work.

I tried the troubleshooting guides and it keeps doing the same. 

I thought the drive was bad. I tried it on a Mac and a windows PC and it was OK. Then, I tested it on my wife’s Iphone (6 PLUS iOS 10.3.3) and it worked perfectly.

So, we did a factory reset on my daughter’s phone to see if some setting was on the way, but it keeps giving the same error.  

Help please!

have you checked the lightning port to see if there is lent or dirt in the port that may be blocking the pins not allowing it to make a data connection?

I would also try connecting the phone to the computer to see if it can connect normally to a computer.