Invalid Password message iXpand

Although the password I am using is correct and opens the secure access vault when plugged in to my MacBook, I receive an Invalid password message when trying to open the vault on my IPhone 8 and Ipad. The password is definately correct, but the mobile devices won’t accept it. I have deleted and reinstalled the iXpand app on both but still wont work. Anyone else have this issue?

1 Like

have you tried enabeling the touch ID to unlock the vault? do you see the same issue?

also is your password using any special or double byte characters? 

Hi

I have the same exact issue which suddenly seems to have cropped up. No issues with accessing the secure vault on my windows computer but i cannot get into my secure vault in the iXpand app. I have tried the following

  1. Changed passwords a few times on my desktop to ensure there are no problems with the type of passwords (have tried the simplest ones like “helloworld1” or “abcdef1”)

  2. Deleted and reinstalled the iXpand app a couple of times

  3. Enabled and disabled the touch ID to unlock the vault 

Is there the result of a new upgrade - I see the app was upgraded a couple of weeks ago

HELP!

Regards

I guess i figured it out - i had to delete my secureaccess folders and execution file on my iexpand - reinstall it and then retransfer files to the vault on my computer - seems to  have done the trick. Not sure as to why this occured but I glad I found a solution

Regards

I don’t know how old these previous post are but I’m having the same issue. I’m hoping some one has a better solution than Sandisk tech support. Vic Ms only answer is for me to delete all my files and start over. Kinda defeats the point of buying the drive.
IM TYPING IN THE CORRECT PASSWORD. I can’t get anyone to understand that. When I type it in, it says “invalid password” but it goes to the page with al the files, it just doesn’t let me open any. It also does it when I use the touch ID feature. When I purposely type in the wrong password it gives me a “password incorrect “ message .
It was working fine for about 1 week, it worked that morning, then when I went to access it again this issue started.
Can anyone help!?!?!?

1 Like

I have exactly the same problem… i use my drive un a daily basis … today, trying to access my vault, asked me for the password as usual but (i always use my touch Id either for my iphone pr ipad)  today it did not recognized my touch id !! And when i put my password didn’t recognized it either. Password is correct. I noticed that when i put any wrong password it appears under the password field “wrong password” ( first picture) but when i put the correct password, is a separate pop up message stating password is wrong.(second picture)

any help will be appreciated. I have very important files in the vault, so please the option to reformat the ixpand drive is not an option for me… thanks on advance.

I’m seeing the same problem, and like others I know the password is correct.  How do I know? - because the app immediately rejects an invalid password, but if you get it right, it bounces out to an “Invalid password” dialog.  Furthermore - if I go to Change Password, and enter an invalid password, I cannot proceed to Change password - but if I enter the correct password, it lets me try to change the password - but then fails on commit.

I don’t know if the problem is caused by securing files from different devices.  I started by securing some from my iPhone, but then plugged it into my iPad to do the same.

First time back using it with the iPhone, and I have this problem.

Don’t know yet if the iPad will allow access - but it’s clear the app knows what the right password is.

Seems like a nasty bug either way.

Did anyone find a resolution to this issue.

1 Like

Doesn’t work from the iPad either - which also clearly recognizes the password as correct. 

It is dec 2019. I got the same problem on my iXpand mini drive - invalid password when getting into vault on iPhone.
I search on internet n can’t find a solution.
Somehow I plug the drive into pc n same issue when accessing vault but the error is diff - invalid parent path in archive.
Search using this n get a hint to solve.
In computer, open folder - iXpand n rename the file index.dat to indexdat ( remove “.” )
Then open the vault again n will ask to repair the index.
After some time ( depends on how many vaults ), it is done.
Can access back the vault using password - no error. But the secured data might not be recovered. It depends how u put the files / photo into the vault before.
If it is copied from iPhone to iXpand then secured , sorry can’t recover the correct index n can’t see the data.
If it is copied using usb from pc to iXpand drive, it is able to access back.
Also i can reproduce the error by exporting WhatsApp chat history n save into iXpand drive . This will ruin the index n cause the error. I guess when moving data into iXpand drive by other app inside iPhone , will cause the error.
Better use the iXpand app to copy photo , music … for data like WhatsApp chat history , I export to a certain place in iPhone, then copy it using app like FILES or FOLDERS into iXpand drive.
This is verified ok on my iphone .

This is an old thread,i don’t know if OP will come back.

There is no fix on here, I can find nothing online, can someone help?? I have lost thousands of photos stuck in the vault, my password is correct. What is the fix? This I’d obviously a common problem

Thank you very much. I have solved my problem using your solution.
Further more, even if my files were copied from iPhone, I recovered the correct index. Here is my solution (when you try this, please backup your data!!!):
I am very lucky that I found some .temp files in the vault folder, and one of these .temp file (system hiden) has the same modified time. I guess this .temp file is the correct index.dat file. So I just delete the old index.dat file (which is 0 KB, and this is the reason of invalid password), and change that .temp file name into index.dat. Then using PC software to repair the index file, when it is done, I can access my vault folder and see the correct data.
I hope my experience could help other guys who meet this problem.
I am not a native speaker, so my English expression may be confused. So I will check this thread and answer questions these days.