Intel RST removes ability to see or select both drives in SSD Dashboard 1.4.3

Save yourself some headache if your running RAID with Intel RST on Win 10…

Installed Intel Rapid Storage Technology application & driver.

Sandisk SSD Dashboard 1.4.3 lost ability to see and choose 2 SanDisk Extreme Pro 240GB drives.

Rolled back to Intel Rapid Storage Technology application & driver.

Sandisk SSD Dashboard 1.4.3 resumed ability to see and choose 2 SanDisk Extreme Pro 240GB drives.

Microsoft Windows 10 Pro 64 (10.0.10586 Build 10586).

Typed above too soon, I was typing as I was experimenting with rolling back driver and confirming newer driver breaks Dashboard’s ability to see or select individual drives (it does).

The part above that is inaccurate is that I was NOT able to downgrade the Intel RST application!

Now I’ve opened up a can of worms…

If I use the older driver Dashboard fully works but the newer Intel RST application will not launch.

If I use the newer driver Dashboard loses drop down selection but Intel RST application launches.

So, if I’m unable to figure out a way to clean wipe the newer Intel RST, I won’t be able to install the older Intel RST, which means I’ll have to toggle driver/restart depending on which program (Dashboard or Intel RST) I want to use. If anyone has any insight on how to easily remove all remnants of the newer Intel RST, it would be much appreciated (Restore point didn’t do it).

Hopefully SanDisk will update Dashboard to work with newer Intel RST driver. There wasn’t anything wrong with my previous Intel RST version so I really wish I’d left well alone.

Update - Tried Intel RST with SanDisk SSD Dashboard 1.4.4 and results are the same, you will lose the ability to see both RAID drives in Dashboard, only Disk 0 will show.

I sorted out the other fiasco, somehow I had started out with Intel RST Application and Driver. So when I uninstalled Intel RST and tried to reinstall Intel RST it would fail because the driver was newer.

I downloaded Intel RST Application and it installed fine and enables SanDisk SSD Dasboard 1.4.3 & 1.4.4 to see both drives in RAID on ICH8R/ICH9R/ICH10R/DO SATA RAID Controller.

Yup.  I was using dashboard (newer!) and RST and it under status it was broken and showed my 1TB RAID array and under performance it also didn’t allow me to see the performance chart or configure TRIM…

bad: iRST… badly lists 1TB raid


So I’ve now just reinstalled the older and it’s good and I can goto preformance and check performance and do and configure trim… 

good: iRST properly lists Sandisk SSD


Another thing is that two days ago I’ve just had my system start freezing and had iaStorA /device/raidport0 event 129 timouts … I think I’ve been running for a while (ok it seems it’s been 12 days) … but something broke and I’ve had to fiddle with power settings to fix things maybe… they’ve been good again for the past day after disabling some stuff like “Link Power Management” and other HD power settings.   Now I’ve also taken this other step and reverted iRST.

So I had been having those “Reset to device, \Device\RaidPort0, was issued.”  with EventID 129 from source “iaStorA”. But while I think that may have been fixed after disabling various power options yet perhaps those may not even have been needed, had I just reverted to the older iRST as have I done now, and perhaps that may also have fixed that iaStorA eventID 129.

Are sandisk support staff reading this and can we get some traction towards getting this fixed??!