How to get my tags recognized?

I thought I was enough computer literate to get this right but appearantly not.

So I loaded 6 albums to my Clip, into the music folder as it says in the manual.

They are all tagged, so I would assume to see 6 albums under Music-Albums

But this is what I get:

Play all and Unknown

If I chose Play all it starts with the first song on the player

If I chose Unknown I get to the “Songs” category and again ALL songs (of all 6 albums) are listed. What’s worse, only 1 album is recognized and it says e.g. Abba-Fernando. All the others just say 01-SongXY

But all are tagged with MP3tag.

If I chose Music-Artists I don’t get a list of the artists on the Clip (as I get e.g. on my Nokia N78 Phone) but I get:

Play All and Unknown

If I go to Unknown I come to the Albums category and again like above all songs appear.

So what am I doing wrong here?


MP3Tag defaults to ID3v2.3 UTF-16.  The Fuze has some problems with Unicode encodings.  Set it to write ID3v2.3 ISO instead and it should work fine.

I believe support for ID3v2.4 and Unicode encodings is coming in one of the next firmwares, but for now you have to use ID3v2.3 ISO.

Message Edited by Skinjob on 12-09-2008 09:26 AM

Can I do this in a way that it automatically converts the tags?


I tried to change the setting in MP3tag and opened the albums, saved them and transfered them to the Clip but nothing at all has changed…

Ok now I tried this:

Deleted all albums on the Clip, deleted the MP3 tags from 2 albums on the PC. Rewrote the tags from amazon-database using these settings:

And copied to music folder on the Clip.

Same thing. What am I doing wrong?

The thing with the playlist works but still I’d like my tags to work.

Thanks for any help!

You might try in the Schreiben/Write section only checking ID3v2.3 tags, not the ID3v1 tags and change the option from ISO-8859-1 to UTF-16.  Also, try unchecking the box for Entfernen/Remove ID3v2.

That’s exactly the same settings I use in MP3Tag and I have no problems.

A puzzling predicament!

Interesting.  After deleting the files from the Clip, and reloading them with the corrected ones, did you get a “refreshing database” message?

Try this for an experiment.  Connect the Clip in MSC mode, and delete the mtable.sys file in the root directory, then unplug.  After the refresh, are your songs now available?

Bob  :dizzy_face: