How do I get audiobooks to work? I am seriously frustrated

I’ve updated firware to 2.37.01.  I’ve got 561 .mp3 tracks for one audiobook.  All these tracks are in the same folder.  The filenames are sequential.  I’ve also used kid3 and sequentially named the “title” sections so they will play in the proper order.  The “album” field of every one of these 561 tracks are displaying the book title.  I have switched “genre” to “audiobooks” for every track as well.  I manually copied by drag and drop to the audiobook folder.  When I use the player’s menu to access the book section, it says that I have 561 audiobooks.  Can you please make a very precise tutorial for audiobooks that is easy to understand and easy to follow, using examples.

Does the version of id3 tag make any difference?

for instance, Step one:  Make sure all tracks are in the same folder

                       step two, using an id3 tag editor, make sure all the “Album” fields show the exact same book title.

                       Step three, make sure the “title” fields are numbered sequentially so they play in the right order.

Etc, etc.  Show some screen shots too please.  I’m so tired of trying to get books to play correctly on this thing.  I’m about ready to put my device up for sale on ebay and get another brand.

Please help me.

Your best bet for now (and what I do) is to put audiobooks in the music folder and make sure they are not tagged as audiobook in the genre field.  You can still tag it something like “Spoken” if you want the tag to make some sense, or just leave it blank.  Then access the audiobook from the music section on the player instead of the audiobook section.

This is quite stupid, I know.

I really hope they fix this in the next firmware update.

I regret I do not have the time to spell this out in a step-by-step fashion with screenshots.

As for ID3 version, the Fuze+ likes  ID3 v2.3 ISO 8859-1 (Latin-I) best.

Thank you for that reply.  It’s a workaround at least.  I hope they fix the book issue too.  I’m not a computer gadget person, but really, how hard can it be?  My clock on the Fuze+ is also wacky now.  It doesn’t keep time while it’s charging.

Change the genre of your books to podcast in Windows Media Player or via Explore.  With WMP sync the book over to you player.  The book will play from the podcast menu.  If  you transfer the book via Explore I would put it in the music section for consistency.   On rare occasions the book will not play in the correct order.  Then drag the book from the music section to the podcast section and it will play correctly.   I would not move every file.

By playing books in the podcast section you will not completely lose your place in the book after on playing one music album.  Look in my posting title ‘restarting audiobooks’ on how best to restart your book.

Hope this response is not too late. 

I’ve got my books loaded perfectly in WMP.  They also show in perfect order in Explorer.  I sync’d them to Podcastsin the Sansa, which thoughtfully changed its name to Books.  In RealPlayer, the Sansa listing also shows it in order. In Explorer, the Sansa shows them in order.

BUT NO MATTER HOW MANY TIMES I DO THIS, IT PLAYS THE BOOK RANDOMLY!  In other words, instead of Track 1 Volume 1, Track 2 Volume 1, ands so forth, it plays Track 5 Volume 3, Track 7 Volume 4, etc.  How do I get it to play right?


The only thing I know to do (for now) is to play them as “Music”.  Make sure the genre is not tagged as Audiobook and put it in the Music folder on the player.

I realize this is ridiculous, and I really hope they fix this in the new firmware, but as it is, the only way to use mp3 audiobooks easily on the Fuze+ (without manually editing tons of track titles) is to play them in the music menu.

I tried to movie it to the music file.  It lost half the treacks.  Now it has odd numbered tracks for the odd volumes and the even-numbered tracks of the even-numbered volumes.  Figure that one out!

Do you have the track # tags properly set?  The music section depends on the track # tags being set properly.

When and if they introduce folder browsing you will not have to bother with all this so much.

Books that have mp3 file titles start with single digit track numbers, or title that are all words, will need to be sorted but the file name.  Using Explore, drag the file from music to podcast or from podcast to music.  You will get a window indicating “moving.”  When you look at this file in podcast it will play in order.   If you have any books have leading zeros, like chapter 01 or 002-The Very Big Door, do not move them around.  

If you have a book that will not play correctly after moving, I would like to down load this book.  I asked for one of these in another posting. 

If you were playing the book when you changed the genre, it was not changed.    This will cause some files to show up in podcast and a few in music. That file can be updated on your computer and in Explore and copied into the player folder. 

Tell me how to attach a file here – I’ll be happy to send it to you.

One easy way to share a book is to copy the internet location of the file as shown below.  I can then copy this info into my web browser and go the location of this file.     Try this web address below to see what I am trying to convey.

If this does not work for you I will come up with another option.  

@bonhommerichard wrote:

I tried to movie it to the music file.  It lost half the treacks.  Now it has odd numbered tracks for the odd volumes and the even-numbered tracks of the even-numbered volumes.  Figure that one out!

I do recall something like this happening to me back at my start of using MP3s to put on disk.  I eventually determined that the files album  names were not all spell the same.  Some had  two spaces extra spaces.  If the book you downloaded has multiple authors, the Fuse+ may have put the books in multiple files.  Albums name could also be inconsistent. WMP will try to keep thing all together. 

I am still looking forward to see what book you are having issues with.