G-Raid Shuttle 4 won't turn on

I just got two 48TB G-RAID Shuttle 4s, and neither of them will turn on. When I press the power button nothing happens.
I’ve tried plugging them in to different outlets, and it didn’t make any difference – they still do nothing when I press the power button.

I’ve also tried holding the power button down, still no luck. What’s going on with this?? Is there some secret process to turn them on, that isn’t documented in the manual? Or did I somehow get two identical dead drives?

3 Likes

Well, I talked to tech support and they said I had to return the drives. But I still desperately need some fast, high-quality storage. If I order two more of these drives, how can I be sure they will work? And not just the hardware, but the driver software wasn’t working either!

Is there any driver software for these drives that will work on an M2 MacStudio?

Is there any way to be sure I will get drives that power up when I turn them on?

2 Likes

I ordered two more of these drives from a different seller on Amazon. Got them today, and guess what? THEY WON’T POWER UP! Same issue I had with the last two. I plug them in, push the power button, and nothing happens. The indicator LED remains dark, the fan doesn’t move, no sounds, nothing.

What the hell???

2 Likes

I am also facing a problem like this, should I ask it here, or have to create a new thread?

1 Like

That is an adapter failure. Make sure you are using the proper adapter and that is outputting 19v and 4amps.

Power Adapters for SanDisk Professional Products (wd.com)

1 Like

Nobody from tech support ever answered my questions here.

The first two times I called tech support all they did was tell me to return the drives, which I did. After the third set of drives had the same problem, they finally put on somebody who knew what they were talking about. It turns out that (A) the drives will NOT power up unless they are connected to the computer; and (B) the if it’s not a Thunderbolt cable, or the cable is faulty, then it won’t power up. In my case it turned out I had a faulty cable. (Just to be clear, this was not the cable that came with the drive.)

ALSO, it won’t power up if you don’t have the driver software installed, so make sure you do that first.

I hope this helps you!

1 Like

Follow all the directions here to install G-Raid shuttle: