Fuse not recognised by ANY computer

I have owned (and loved) my fuse for almost 2 years now but a couple of months ago I plugged it in to my laptop to add some audiobooks and the laptop couldn’t “see” it. 

The fuse was charging up Ok as soon as I connected it, but Audible Manager programme said no player was connected, it doesn’t show up in my computer or the device manager or anywhere! 

I have tried using the MSC mode, the MTP mode and the autodetect mode - but nothing works.  I have tried my own cable. my husbands cable and a brand new cable - still nothing!  I have tried 4 different computers and laptops, but it is the same on every one, the Fuze will charge but is not visible as a device (and yes I have looked for hidden devices)

I’ve tried connecting it to the firmware updater but the updater keeps telling me to connect my device.  I feel as if I am going round in circles.

I’ve tried turning the on/off switch to lock (orange dot showing) and holding downd the left arrow key but it makes no difference.

The only thing I haven’t done, and dare not do is to reformat it.  I don’t want to do this because right now I at least have 6 GB of audiobooks and a few music files on there, and as I can recharge it without a problem I can at least still listen to the audio books I have, if I reformat and it doesn’t work I will have no way of getting my audio books and music back onto the player.

I have seen various posts when doing a google search that tell me I am not the only person to have had this happen, but none of the posts carries a solution.

PLEASE can anyone help me?

Thanks in advance

The cord carries power and data. Power is working. Data isn’t.

It doesn’t sound good.

You could try disconnecting from the internet and turning off your antivirus / internet security / firewall software on the distant chance that it’s interfering with the connection. Don’t forget to turn it back on before you go back online.

Beyond that,  since you have tried various cords, and you are able to recharge, I would guess that something is wrong with the data connectors in the Fuze itself.  But that is just a guess.

I’d suggest calling the tech-support number for Sandisk in your country. 


I have the exact same problem - am using it for audiobooks as well - the firmware updater also jsut circles and teh manual version says to drag teh unzipped fiels to teh root of teh sansa fuze - whcih I can’t do becasue teh  computer doesn’t see it - I’ve tried 4 differnt computers - my sansa fuze is fairly new - haven’t used it much

any help is appreciated.

I’ve fixed my problem - soemwher I came across a reference to install windows media player 7 - did that - and rebooted and  everythgin is working - computer sees  player - audible sees palyer - all is good

I had the same problem as well… I could not get any PC to recognize this device… I uninstalled and reinstalled drivers which was a waste of time… I eventually found the manual… You can reset the device by simply sliding the power button on the right side towards to the right side (power symbol) and holding for ten seconds.  Afterwards turn back on by sliding to the left (hold).