Firmware Issue with Similar Folder Names

Hi all. Using Sandisk Clip+ firmware 1.02.18.

I have the following folder structure:

\MUSIC\Led Zeppelin\Led Zeppelin I

\MUSIC\Led Zeppelin\Led Zeppelin II

\MUSIC\Led Zeppelin\Led Zeppelin III

\MUSIC\Led Zeppelin\Led Zeppelin IV

All music within are .FLAC encoded

When trying to navigate to those folders on the Clip+, there is only

\MUSIC\Led Zeppelin\Led Zeppelin I

But the music from all of the other folders above are in there too.

I was using .16 firmware but upgraded to .18 to see if it fixed the issue, but it did not. My only resolution was to rename the folders as follows:

\MUSIC\Led Zeppelin\Led Zeppelin 1

\MUSIC\Led Zeppelin\Led Zeppelin 2

\MUSIC\Led Zeppelin\Led Zeppelin 3

\MUSIC\Led Zeppelin\Led Zeppelin 4

This solved the problem, but I’d rather use the old folder names.

Well, the short answer is, the Clip doesn’t like the Roman numeral system and wants you to use the Arabic number system.  Issue solved (and good for you in determining this!) . . . .

I think the same thing happens if you have multiple CD sets and the discs are labeled as Disc I, Disc II, Disc III and so on. You’ve got to change them to Disc 1, Disc 2, Disc 3, etc.

I was unaware of this isuue, but if as stated it’s a bug. I could understand (well actually I couldn’t, but would accept as an excuse) if these were non standard characters (> decimal 128), but they’re not so it is a bug.

That’s really odd. It should read the roman numerals since the player can also see it as letters. Have you tried it with no spaces?