Extreme II SSD Firmware version 1411 for Mac download and installation instructions

SanDisk has released the ISO firmware images to allow SSD firmware update on operating systems that are NOT supported by the SanDisk SSD Dashboard. Each capacity drive has a separate Firmware ISO. You MUST use the correct firmware ISO for the capacity SSD you have installed.

WARNING: Applying the wrong firmware ISO to your SSD product will render the drive unusable! Please confirm the capacity of your SSD product before proceeding with the firmware download and update.

Step 1 - Verify the capacity and model number and capacity of your Extreme II SSD and download the corresponding firmware ISO

NOTE: You will need to know if your system is 32 or 64 bit system and download the correct ISO for your system

64 Bit systems
SanDisk Extreme II SSD 120GB x64 FW 1411
SanDisk Extreme II SSD 240GB x64 FW 1411
SanDisk Extreme II SSD 480GB x64 FW 1411

32 Bit systems
SanDisk Extreme II SSD 120GB x86 FW 1411
SanDisk Extreme II SSD 240GB x86 FW 1411
SanDisk Extreme II SSD 480GB x86 FW 1411

Extreme II SSD Firmware 1411 for Mac release notes

Step 2 - Burn the saved image file to a CD/DVD with another software application then boot from the CD and perform the firmware update.

Burn image with Mac: Use Mac Disk Utility
To get started burning your ISO file with OS X, you need to launch the Disk Utility. The Disk Utility can be found at Finder > Applications > Utilities > Disk Utility. You also need to make sure that you have your ISO file saved directly to your computer, preferably on the desktop.

Click the File button on the OS X top navigation bar and select Open Disk Image. This should open up the Select Image to Attach pop up box. Navigate to the ISO file that you want to burn, select it, and click the open button.

This will automatically mount the disk image into OS X. Now, you should see the ISO file listed in the left hand side drives list within Disk Utility. At this point, insert a blank CD or DVD into your computer if you have not already done so.

Select the ISO file from the left hand side drives list by clicking it once. Select the Burn option from the top toolbar within Disk Utility. A drop down menu should pop down, asking you to verify the burn. Click the burn button.

That’s all there is to it. Now all you have to do is wait for your disc to burn. ISO files tend to be somewhat large in size, so the disc burning process may take up to 15 minutes, depending on the speed of your burner.

Restart your computer with the firmware disk inserted, press and hold the “options/alt” key while the computer restarts to get into boot menu.  Select to boot from CDROM.

  1. Your system will boot to the SanDisk Firmware Updater
  2. Enter the drive (i.e. /dev/sda ) you want to update from the list displayed (The drive name is indicated by the red circle in the image below)

  1. Press ENTER to start the update

  1. When the update is completed, type “n” and press ENTER to shutdown computer

  1. Restart computer, and remove the boot CD/DVD from the drive

Has anyone been able to apply this update? All I’m getting is an update failed message. After that, it asks if I’d like ot try another drive - if I click yes, it says ‘there is no ssdson this system that match teh model string of this update’.

Which is corerct, as the serail number of my drive is different to the serial first shown.

Running Yosemite, 64bit 240gb file.

I am unable to apply the update as well.  I was so exited to get this slow wake issue fixed.  I wonder if Sandisk is aware?

I also get firmware update failed. I need this fix, very badly! 

For those of you experiencing FW update failed error can you please provide the model of computer you are attempting the update in?

Forum Admin


I am using a Early 2011 Macbook Pro with a 240 GB Extreme II

I have 13" early 2011 (MacBook Pro 8,1). 

SSD: 480 GB 

Firmware version: 64BIT 

13" Early 2011 Macbook pro running Yosemite.  240Gb Extreme II- 64-bit

Late 2011 macbook pro, running Yosemite.

The update software has a totally different serial number to my SSD which is causing the issue. It’s the right software from the list though, 240GB 64Bit. 

Same issue here.

MacBook Pro (15-inch, Late 2011)

Processer  2.5 GHz Intel Core i7

Memory 16 GB 1333 MHz DDR3

Graphics  AMD Radeon HD 6770M 1024 MB

OS: Mac OS X 10.10 Yosemite

I was very much looking forward to be done with the 30 second delay when waking up my computer. Rebooting it is faster than that.


MacBook Pro (15-inch, Early 2011)

Same deal… the serial numbers don’t match.

Has there been any update on this? 

Getting same problem, Early 2011 Macbook Pro 17".

Also, 32 vs 64 bit.  Does it matter when using the boot disk?


same problem; update firmware failed.

  Nom du modèle : MacBook Pro

  Identifiant du modèle : MacBookPro8,2 - early 2011

  Nom du processeur : Intel Core i7

  Vitesse du processeur : 2 GHz

 Capacité : 480,1 Go (480 103 981 056 octets)

  Modèle : SanDisk SDSSDXP480G**      **                

  Révision : R1311    

(tried with version 64bits )

I’m failing to update as well.

MacBook Pro (13-inch, Early 2011)

OSX 10.10

This is quite frustrating…

The update also fails on a Macbook pro early 2009 13inch.

If anyone from Sandisk is reading the forum, I can get more detailed info about the failure as the debugmode can be changed when the CD boots up. Let me know and I will send a pic of the error and post how to chnage the debug mode for others to follow.

I wrote the ISO to a cdrom,and updated the ssd  successfully on a windows laptop.

Model Name: MacBook Pro (early 2011)

Model Identifier: MacBookPro8,2

Processor Name: Intel Core i7

Processor Speed: 2.3 GHz

OSX 10.10

Sandisk Extreme II SSD 480GB

Please have an engineer address this.


What is becoming apparent is that the update was not tested on a MacBook Pro. Because the update fails with an error when sending an ATA command “DOWNLOAD MICROCODE” to the drive. There have been many reports of sucess using a Windows machine though which makes me wonder about which machine was actually used to test the update.

To check the error code:

when the menu appears enter “e”, then “e” again to edit the command line.  The serial number can be changed as well as the debug mode. Afterwards “enter” followed by “b” (boot) will continue the boot process.  Use at your own risk!!

I wish I had read this forum and your post before opening my MBP again.  Anyhow I removed the Sandisk Extreme II SSD and temporarily swaped it in an older Compaq laptop  HDD drive bay - booting the 32bit version of the CD on the CompaqI was able to update to 1411.  The wake from sleep lag is now gone after reinstall in MBP.  This was quite a hassle but it worked.

Sandisk slap on the wrist for making a patch for Apple that apparently was tested on a non apple laptop.

I solved this issue for me.

I suspect the problem lies in the way Yosemite handles partitions and formatting of drives.

Anyway, what I did was:

Put the SSD into my BlackMagic Cinema Camera and formatted it in the EXFAT option (which evidently also deleted all partitions and created a single one).

Put the disk back into my macbook and booted from the firmware updater CD.

And it suddenly worked.

If you don’t have said camera (and I assume most people on this thread don’t),

you might still have windows machine that would allow you to do the same thing, or try and format it that format on the mac.

I suspect, however, you’d also need to remove all other partitions (mac recovery partition etc), for this to work.

A clean Yosemite install may also have used the new partition scheme, which DiskUtil can’t change. This is something you can revert to the old thing though (google search it).

Anyway, it was a major headache.

If you’re going to do any of the above, make sure you have a current TM backup.