digital distortion e250

I just bought an E250 and annoyingly, it appears to be faulty, any mp3 I play ends up breaking up with digital distortion…

Ive tried my own rips, friends mp3’s, downloaded mp3’s, different bit rates etc so Im sure its not corrupted files.

I tried mp3gain as suggested in a post on here on files other than my rips with no difference.(my rips done with WaveLab 5 & normalised to -1, WaveLab is better than mp3gain, but its not free!)

Every file plays and at some random point in the playback starts to distort and sometimes hangs the player, Video playback has the same problem as well with digitally distorted sound.

Wav files, FM radio and voice recordings play no problem.

Ive updated to the latest firmware with no difference.

Has anyone else had a problem like this?

I hope I’ve overlooked something that is causing this problem so I dont have to do the sandisk support thingo (groan)

Thanks in advance for any feedback. Tony.  Sansa e250v2  V03.01.16a

You could TRY updatingthe firmware, but if that doesnt’ work I would just return it to the seller and get another.

Chances are, if you just bought this it is a refurbished unit. Contact the dealer you got it from immediately as re-furbs typically do not come with a very long exchange or return policy.

You’ve upgraded the firmware to the latest available. The only other thing you could try (with a v2 model) is to format the unit and re-load your music to see if that would make any diffeerence. But honestly, I don’t think that it will.

If it indeed is not a re-furb, and it’s under a year old, then by all means contact SanDisk Tech Support. (They won’t/don’t honor the warranty on re-furbs). They most likely won’t have any of the same model to give you as it’s been discontinued for some time now, but they might offer you the same size (2GB) Fuze for a replacement.

If it is a re-furb, and you’re past the 3 day (or whatever) excuse-for-a-warranty the dealer gives on it, I fear you may be SOL (something outta luck).

Message Edited by Tapeworm on 07-25-2009 03:52 PM

Try reading the faqs.b

**bleep**, looks likes its got a crap chip in it hey…

Its not a re-furb so I’ll contact Sandisk support, wish me luck! Thanks for the replies guys.