Clip+ FLAC files bitrate issue?

Hi,

I am seeing a weird bug on the Clip+ using FLAC files.  I ripped two tracks from a CD to FLAC format, gave them the same album tag, and transferred to the Clip+ using MSC mode.  So now there is an album on the player with two tracks.  When it gets to the end of the first track, it does not go to the second track.  The player hangs.

I brought this up with tech support today, and they told me that, with FLAC files, bit rates of over 600 kbps are not supported.  I asked if this is a bug that could be fixed, or if it’s a fundamental limitation with the player, and they said the latter.

I was just wondering if anyone knows anything further about this.  I would have liked to be able to copy tracks losslessly from CD to my computer and then simply transfer the files to the Clip+ and listen to them.  One would have thought that this would be straightforward.  The Clip+ user manual, as far as I can tell, says nothing about a bitrate limitation.  It just says “FLAC and Ogg Vorbis are variable bit rate.”  Any idea what’s going on, anyone?  Thanks!

Mark

p.s. In case it’s relevant, I use EAC for ripping; it calls an external converter to convert to FLAC.

i dont think it is a bit rate issue, it is a PCM (pulse code modulation) bit resolution issue. Sansa products only support 16bit FLAC. 24Bit FAC are not supported. 

I rip CD’s to FLAC with EAC all the time (800-1100kbps & above). I haven’t had one yet that didn’t play on my Clip+. In fact, that’s all I have on it and a 32GB card in it is FLAC.

Thank you drlucky and Tapeworm for your replies.  These are 16-bit files, ripped from CD.  Maybe there is something wrong with my unit.  I have the latest firmware (V01.02.18A).  I have small files that create the error condition and I wanted to send them to customer support, but they distracted me with the bitrate explanation.  I sure wish I knew whether they could replicate the error.  I would be happy to post the files if there’s any way to do that.

Another weird thing I noticed just now is that the first letter of the track title has, in some cases, been changed to a Chinese (?) character, but I assume that is another issue entirely.

p.s. Tapeworm, I am using flac 1.2.1b, and in EAC, under Compression options>External compression I have the command-line options

-6 -V -T “ARTIST=%artist%” -T “TITLE=%title%” -T “ALBUM=%albumtitle%” -T “DATE=%year%” -T “TRACKNUMBER=%tracknr%” -T “GENRE=%genre%” -T “COMMENT=%comment%” -T “BAND=%albuminterpret%” -T “ALBUMARTIST=%albuminterpret%” -T “COMPOSER=%composer%” %haslyrics%–tag-from-file=LYRICS="%lyricsfile%"%haslyrics% -T “DISCNUMBER=%cdnumber%” -T “TOTALDISCS=%totalcds%” -T “TOTALTRACKS=%numtracks%” %hascover%–picture="%coverfile%"%hascover% %source% -o %dest%

and the Bit rate is 768 kBit/s.  I can’t think of anything I’m doing wrong…?  Thanks in advance.

Mark

@mdeb wrote:

I sure wish I knew whether they could replicate the error.  I would be happy to post the files if there’s any way to do that.

 

Another weird thing I noticed just now is that the first letter of the track title has, in some cases, been changed to a Chinese (?) character, but I assume that is another issue entirely.

If you can upload some sample files to a file-sharing site and post a link to them here, I’m sure they can look at them.

Yes, a Chinese character could have something to do with it.

I can check my EAC settings tonite when I get home, but at first glance you seem to have an over-abundance of additional command line parameters that probably aren’t necessary and could be in fact causing your issue.

I have a clip+ with 32GB SD card that is used exclusively for FLAC. All of the bitrates are 600+. No problems.

@tapeworm wrote:


@mdeb wrote:

I sure wish I knew whether they could replicate the error.  I would be happy to post the files if there’s any way to do that.

 

Another weird thing I noticed just now is that the first letter of the track title has, in some cases, been changed to a Chinese (?) character, but I assume that is another issue entirely.


If you can upload some sample files to a file-sharing site and post a link to them here, I’m sure they can look at them.

 

Yes, a Chinese character could have something to do with it.

 

I can check my EAC settings tonite when I get home, but at first glance you seem to have an over-abundance of additional command line parameters that probably aren’t necessary and could be in fact causing your issue.

This sure looks like the issue to me.

Here is my command line… %D%C%N %T. CD artist, CD title, track number, track title.

Any further alterations I decide I need beyond that, I would make with http://www.mp3tag.de/en/ afterwards.

@marvin_martian wrote:


@tapeworm wrote:


@mdeb wrote:

I sure wish I knew whether they could replicate the error.  I would be happy to post the files if there’s any way to do that.

 

Another weird thing I noticed just now is that the first letter of the track title has, in some cases, been changed to a Chinese (?) character, but I assume that is another issue entirely.


If you can upload some sample files to a file-sharing site and post a link to them here, I’m sure they can look at them.

 

Yes, a Chinese character could have something to do with it.

 

I can check my EAC settings tonite when I get home, but at first glance you seem to have an over-abundance of additional command line parameters that probably aren’t necessary and could be in fact causing your issue.


This sure looks like the issue to me.

Here is my command line… %D%C%N %T. CD artist, CD title, track number, track title.

Any further alterations I decide I need beyond that, I would make with http://www.mp3tag.de/en/ afterwards.

OK thanks but could you please be a bit more explicit about what the command line should look like?  I tried following your instructions and I got “Invalid replacement tag found!”  This is in EAC, Compression options>External compression>Additional command-line options.  Thank you.  (Should I check “Add ID3 tag”?)

Mark

@tapeworm wrote:


@mdeb wrote:

I sure wish I knew whether they could replicate the error.  I would be happy to post the files if there’s any way to do that.

 

Another weird thing I noticed just now is that the first letter of the track title has, in some cases, been changed to a Chinese (?) character, but I assume that is another issue entirely.


If you can upload some sample files to a file-sharing site and post a link to them here, I’m sure they can look at them.

 

Yes, a Chinese character could have something to do with it.

 

I can check my EAC settings tonite when I get home, but at first glance you seem to have an over-abundance of additional command line parameters that probably aren’t necessary and could be in fact causing your issue.

OK thank you, I would appreciate that.  Perhaps this is a problem with tags, although when I manually edit the tags to something else the problem doesn’t go away.  I note that when I rip the offending track with Windows Media Player (to wav, and then convert to FLAC via foobar2000, and add tags in foobar) the problem does go away.  However, this is kind of laborious, and EAC ought to work!

Again, your reply is much appreciated,

Mark

@glfnaz wrote:

I have a clip+ with 32GB SD card that is used exclusively for FLAC. All of the bitrates are 600+. No problems.

Thanks glfnaz.

Best, Mark

Just to post an update about this.  Following Oscarilbo’s post  of 10-19-2012 02:31 AM in a thread entitled “differences in USB mode causing issues with firmwares ???”, I downgraded to firmware 01.02.16 and the problem seems to have gone away.

So, should anybody search on “clip+ flac freezes hangs” I hope they will see this message and perhaps this will work for them too!

Mark