The last two time I have tried to charge my Fuse+ with  AC/wall changer, I have not seen an increase in change level.    Today I selected another wall changer.  After 3 hours the unit was showing that it was still changing.  When I unplugged the unit, I got the white battery with a red strip for a second and the unit would not power up again.  Tried resetting the unit. No go.  

Connected to my computer.  Still not able to reset and power back up.  Left unit connected to the computer for another 3 or 4 minutes.  Unit powered itself up and started charging.  

When my unit was new, it would update the power percentage that shows in Vista  under Properties while changing.  Lately the only way I have been able to get an updated reading is to unplug the unit from the computer and plug it back in.   I plug it back in as soon as the unit displays the Sandisk logo.  When the unit shows connected, the power reading is updated.      I think this is a bug with the new firmware.

When I unplugged the unit and plugged it back in after 5 minutes, the change level went from zero to 26%.  After another 15 minutes of changing and unplugging and plugging back in, the charge level was at 40%.  Now at 46%

It is my guess, the wall changers will work fine the next few times I use them.     I think this is another bug with the new firmware.

About wall charger, You need to modify it. Example Instruction.

There is no way to get into my wall changers.   I have had every changing method fail at one time or another.  I am not sure why.  I have a degee in electronics.  I am still thinking through this problem.  The last thing I would suggest for now is modifing or destroying a changer or computer.   

If you have modified your charger for better results with you Fuse+, I would like to hear about your results.  Your results may help me and others understand the Fuse+.

I have two changers that look the same.  I used the same changer on another Fuse+.  When I took the unit off the computer and put on the chager, the charge level was 43% iin the Info section of  Settings.  The Fuse+ was showing a chageing indication in the upper right corner. When I check the unit this morning, the unit was blinking on and off.   When I unplugged it, the unit went black.  When I plugged in another wall changer the very low battery indication was showing.  In less that 10 minutes the unit charge level was at 17%.

The Fuse+ may need to be smarter about indicating charging.  I say “may” becacuse I think I need more data.  Cell phone will tell you if the charger in not the correct type or the chager broken.  

The change % in Vista is minor issue.  This second unit is still running the previous firmware.  It too does not show an updated charge level without unplugging. .