Can't download song to the device--Ubuntu Intrepid user

As dnop & I have said, you MUST unmount the Fuze before unplugging it. This shouldn’t be scary, I think if you right click the 4.1 GB Media icon, there will be some self explanatory option. Choose it and wait for the unmounting process to complete before physically unplugging the Fuze.

 You said ‘I then unplug the fuze, see a “refreshing” notice, then discover that the thing is empty’. The refreshing notice means the Fuze thinks that you have changed the files stored in it. So at least the first little step is working.

Two things:

  1. Where did you look to conclude that the Fuze is empty?  Make sure to check for any ‘Unknown’ items under Artists or Albums.
  2. Where did you get the test MP3 file from? Was it ripped from a CD, or downloaded, or something else?
    Don’t get hung up on what the iPods do - there is some magic that happens under the bonnet to make RB notice them. Even if it is not possible to replicate that for the Fuze, you will still be able to manage content on your player.

OK - here’s how to do it in RhythmBox…

First, the bit of magic that lets RB hook your Fuze. 

Plug the Fuze in. Click the ‘4.1GB Media’ desktop icon so you have a filemanager on the top directory in the Fuze. Right click and ‘Create Document->empty file’. Rename the file .is_audio_player (the leading . is important).

Next, how to rip CDs in RB

I’m going to tell you how to rip to Ogg Vorbis format, because (1) you don’t have to install an MP3 encoder, and (2) the tagging is probably easier (RB rips MP3 files with ID3v2.4 tags which Fuze doesn’t understand). Ogg is not recognised by some players, but if you are using your Fuze, it will be fine. If you want to use MP3 for compatibility with other players, we’ll need to talk some more…

We need to tell RB to use the right file naming for the Fuze. You only need to do this once.

  • Start RB.
  • Go to  Edit->Preferences->Music, and set ‘Preferred Format’ to CD Quality, Lossy (.oga type).
  • Now click the Edit button.
  • Choose CD Quality, Lossy and click the Edit button.
  • In the window that opens, change ‘File extension:’ from _ oga _ to _ ogg _.The Fuze doesn’t understand .oga as a file type.
  • Click ‘Close’ on all the preference panels.
  • Go to  Edit->Preferences->Music
  • Fill in ‘Music files are placed in:’ with some sensible location like Music in your home directory.
  • Click ‘Close’
  • Restart RB

Now we can rip stuff

  • Put a CD in the drive. It should show up under Devices in RB’s left panel.
  • Right click the CD icon, and  choose ‘Extract to Library’
  • A progress bar should appear on the bottom right of RB.
  • If you select Music under Library in RB’s left panel, you should see tracks start to appear.
  • When the prgress bar goes, it’s ripped…

Put it on the Fuze

  • With Music highlighted under Library, you can drag the album or artist or an individual track from the right panel to the Fuze ‘4.1 GB’ icon in RB’s left panel.
  • Once the copying is done, right click the Fuze icon and choose Eject.
  • Wait till its finished unmounting & unplug the Fuze.

 Hope that works for you!

Message Edited by daytona955 on 01-06-2009 01:20 PM

That’s a pretty comprehensive response from daytona955 - I’m hoping mariarhi gets back with some sort of response as I’m starting to form the idea NOTHING gets resolved in these forums!!!

Incidentally, I’ve got Intrepid and use RhythmBox - no issues.

Yeah, I’ve become the guy I hate who says, “Works for me!”.

FYI: Just a quick note.

I downloaded an mp3 podcast to my debian (sid) desktop, plugged in my fuse, which showed up as 2 icons on the desktop, one for the built in memory and one for the added card. I opened the built in memory to the podcast folder, copied the mp3 file in, and ejected (unmounted) both devices. I am now happily listening to the podcast.

My USB mode is set on autodetect, and I usually use rhapsody on windows to load songs/playlists. I see I can use both linux and windows/rhapsody. I am assuming I can do the same for mp3/ogg files, but haven’t tried it.

EDIT: forgot to mention I’m using Gnome Desktop. 

Message Edited by kmoffat on 01-06-2009 04:59 PM

@chimai wrote:

That’s a pretty comprehensive response from daytona955 - I’m hoping mariarhi gets back with some sort of response as I’m starting to form the idea NOTHING gets resolved in these forums!!!

 

Incidentally, I’ve got Intrepid and use RhythmBox - no issues.

 

Yeah, I’ve become the guy I hate who says, “Works for me!”.

Interesting - do you rip to MP3? If so, do you know what version of ID3 tags RB adds to your files?

Chima, I just got back from teaching and grading my 17-year-old monsters. I’m going to try the recommendations, and I’ll be back. Honestly, I’d love to put a “solved” check on this thread.

Message Edited by mariarhi on 01-06-2009 06:16 PM

Daytona, I followed your directions. Changed the oga to ogg, and the 4.1 device appeared on the left of my rhythmbox. I ripped the CD as you said, and it downloaded onto my Sansa. I could actually watch it do so, which is more than I have seen before. I then tried to unmount the device, but a screen came up, stating that an application was preventing the unmounting. I closed everything, tried again, same result. I unplugged the device anyway, and discovered that the Fuze was empty.

This is a huge improvement over what was happening before…I can at least see the device in the RB, and I can at least watch the thing download the music…except for the fact that nothing ends up on my Fuze, probably because something is preventing it from unmounting.

THANK YOU so very, very much for all your help. I now need help in trying to figure out how to unmount this thing properly, so that I get my music.

Would you happen to know how to do this? 

Just a thought: Are you using gnome? My right click menu has ‘eject’ instead of ‘unmount’.

I turned everything off, restarted, and it let me dismount. I now have an album on the Fuze! My next problem is getting individual songs on from various places…how do you guys do that? Is there a preferred site? I’ll put a “solved” on this thread and start another. I am definitely going to save Daytona’s instructions, though. THANK YOU!!! for putting up with a slew up really stupid questions.

No Question is a Stupid Question! I dont use lunix but I am learning a ton from you guys. It will be incredably valuable in the future or if i have to use lunix at some point.

Message Edited by Conversionbox on 01-06-2009 10:30 PM

@mariarhi wrote:

Daytona, I followed your directions. Changed the oga to ogg, and the 4.1 device appeared on the left of my rhythmbox. I ripped the CD as you said, and it downloaded onto my Sansa. I could actually watch it do so, which is more than I have seen before. I then tried to unmount the device, but a screen came up, stating that an application was preventing the unmounting. I closed everything, tried again, same result. I unplugged the device anyway, and discovered that the Fuze was empty.

 

Are you ripping directly to the Fuze or to your HDD and then transfering them to the Fuze?

Just be aware that Linux will cache the file transfer letting you continue. In the background it will continue to transfer the files across the slow USB connection. If you try and unmount the device while it is still syncing you will get the “application preventing” message.

@mariarhi wrote:
I turned everything off, restarted, and it let me dismount. I now have an album on the Fuze! My next problem is getting individual songs on from various places…how do you guys do that? Is there a preferred site? I’ll put a “solved” on this thread and start another. I am definitely going to save Daytona’s instructions, though. THANK YOU!!! for putting up with a slew up really stupid questions.

I’m glad you’ve succeeded :smileyvery-happy: Well done for sticking with it!

Your questions were not stupid. Things are made more complicated by licencing issues, the Fuze’s failure to work with all forms of ID3 tag, and the plethora of ways to do the same thing in Linux, amongst others. Even in the Windows world, things don’t always work well - as you can see in this forum!

I almost put a bit about what to do if it won’t let you unmount/eject, but I thought the post was getting a bit big! BTW, the OS calls it unmounting, and RB calls it ejecting, but it’s effectively the same thing.

Anyway, the first thing to do is wait for a couple of minutes & try again. By definition, RB has been using the Fuze, and it might take a while for to OS to realise it has stopped doing so.

If that doesn’t work close RB completely, and try right-clicking the desktop icon, and using the Unmount option.

The actual process of unmounting can take a few seconds, especially if you have only just finished writing stuff to the Fuze. When the icon has gone from the desktop (or from RB’s left panel), it’s unmounted.

If none of that works, shutting down (not pulling the plug though!) the computer will, as you discovered, force the OS to write the  remaing data to the Fuze and unmount it.

It is probably worth looking at your Fuze in the filemanager and removing any old files left over from your less successful attempts to add tracks. If there are some with similar names to tracks that work, the Fuze may get confused. It is a bear of very little brain, and almost anything out of the ordinary will bother it…

Message Edited by daytona955 on 01-07-2009 12:01 AM

Daytona, thanks again. I’ll go through it, because I tried many times, unsuccessfully, to get the Fuze to work. An entire weekend of unsuccessful attempts, actually :smiley: Yes, it is a bear of very little brain, but not quite so cuddly; there are too many way of doing the same thing on Linux. Btw…would you mind if I posted your instructions on the Ubuntu forums? They might help someone else who is having similar problems.

Feel free to post the instructions where ever you like!

I did have another thought about the unmounting issue while I was out for a lunchtime stroll…

Are you using Ubuntu because you have an older ‘recycled’ PC?

If so, it may only have USB 1.1 ports, which are much slower than the current USB 2 ports. If the Fuse is plugged in a 1.1 port, it will take a long time to transfer a whole album. Even though RB or the file manager say the transfer is complete, the OS will have cached the write in memory, and it will be slowly dribbling out of the USB port, hidden away from view. Until the physical write is complete, the Fuze won’t unmount.

If it is an older desktop, you might improve things with an add in USB 2 card. Just search for ‘usb pci card’ on Amazon. You need a spare PCI expansion slot in the PC’s motherboard to plug it in. Ubuntu will just recognise and use it - you can chuck the Windoze driver CD in the bin! If it’s an older laptop, a usb pcmcia card might help.

Hi all,

I like to contribute some words to this discussion, because I bought my daughter a Fuze 8 GB as a Christmas present and had to solve some similar issues (btw, I am not completely through; software update was no problem). We are using Ubuntu Hardy (8.0.4) on several computers.

Studying the Rhythmbox topic more in detail I found this bug report

https://bugs.launchpad.net/ubuntu/+source/hal-info/+bug/278660

leading to a magic file:

 /usr/share/hal/fdi/information/10freedesktop/10-usb-music-players.fdi

If you go through this file searching for “Sansa” you will find also this line unter an entry for “Sansa Clip/Fuze”:

 <match key="@storage.originating_device:usb.product_id" int_outof=“0x7432;0x7433;0x74c0”>

As our Fuze 8G has the product ID 0x74c1 (shown by ‘lsusb’), it became clear to me that a proper entry for this player is simply missing here. I changed this line to:

 <match key="@storage.originating_device:usb.product_id" int_outof=“0x7432;0x7433;0x74c0;0x74c1”>

saved the file and got a nice mp3-player icon on the desktop as soon as I pluged in the Fuze. Also Rhythmbox is started automatically and reads in all mp3 files, which were moved to the player before via filemanager drag-and-drop. Note: I removed the hidden “.is_audio_player” file before.

What still is missing now, how to handle podcasts and recordings. I also do not know how I can add album art photos. The iPod of my son simply adds them to the database by playing a song which is stored on the iPod via Rhythmbox. The Fuze does not accept the photos this way.

Regards

Guido

Message Edited by gscholz on 01-07-2009 01:20 PM

Message Edited by gscholz on 01-08-2009 12:15 AM

Thanks for the info Guido - it’s useful. I’d not bothered looking at how to do it at a system level as I thought mariarhi would be happier creating a quick file on the Fuze than being root & editing system files.

I haven’t tried RhythmBox before this thread - so I can’t comment on album art in RB. But I used to have a Zen V+, and it worked really well in Amarok via MTP. Amarok will fetch album art from Yahoo, and seems to add it to ID3 tags en-route to an MTP device. It all just worked so sweetly!

Then my Zen broke and I bought a Sansa e260v2. It never worked properly with Amarok because of no v2.4 tags support in the Sansa, and no external uSD card support in Amarok, and because the Sansa wouldn’t support embedded art.

Now I use MSC mode for my e260 & Fuze. I need EasyTag to convert everything to ID3v2.3 and manually embed album art (after manually changing the jpeg size) for the Fuze. And I use a file manager to dump stuff onto the players. That’s backwards progress… Oh well!

Thanks for that information, I used it to find out that the USB id for the 4G Version 2 Fuze is 0x74c3.

I added that to the location in the file you indicated and now I get a nice looking music player icon instead of the external HDD one.

It is recognised as a music player in RB as well.

Daytona, in which case, I’ll copy your instructions to the Ubuntu site, as they could help someone else. Now I’m curious about the other approach…hmmm…must wait till this weekend for that one. I’m not interested in album art etc in any case. I just want to listen to the music. As far as the computer: it’s about three years old, and it showed up stripped of all software. Having experienced the joys of Vista, I was more than glad to install Ubuntu. It’s got the necessary ports fortunately.

Hi all,

I would like to continue my description. Album art is working now. First a short introduction about what happened before:

The situation at the beginning was that I had a complete set of mp3-files ripped by “Sound Juicer”, imported to Rhythmbox and equipped with album art by Rhythmbox. This set was used to feed an iPod via Rhythmbox.

Now the Sansa Fuze came in and first it was necessary to get all files retagged with “tagtool” gaining the proper ID3v2 tags (in batch mode) so the Fuze could identify artists and album names. These files were transfered via filemanager drag-and-drop to the Fuze.

The next step is well known here, so Fuze now is recognized by the system as a real mp3-player.

This is what I did to get the album photos in:

As I found Rhythmbox stores the downloaded album photos in this (hidden) directory:

  ~/.gnome2/rhythmbox/covers/

Studying this forum excessively I found the Fuze needs only very small pictures with 120x120 pixels, more seems to be just waste. There are two solutions to store these photos on the Fuze:

  1. Attach a photo to each mp3 file e.g. via  “easytag” as a tag.

  2. Store a file named “folder.jpg” in the appropriate album directory.

I decided to select version 2) because it is more “lean”, so to say. My proceedings were this: Open the photo in the Rhythmbox directory with “gimp”, scale it to 120x120 pixels and save it to

/media/SANSA FUZE/MUSIC/<artist>/<album>/folder.jpg

where <artist> and <album> were the appropriate names.

That is all, but of course it would be best automated e.g. by a Sansa Fuze plugin for Rhythmbox.

Left now is the video topic.

Guido

Message Edited by gscholz on 01-08-2009 11:21 AM