A problem has occurred in obtaining the device's secure clock

Returning and getting another 8GB was the solution to my problem too after trying all of the other steps.  My clock on the first one was set to 2038 out of the box when I first sync’ed with Rhapsody (why doesn’t it set the time itself?), so perhaps that caused some issue.

Looks like they are having some quality control issues. 

Has anyone had any luck with this error? I am getting it on my year old sansa260e…I’ve reformatted, relicensed…everything…


Which model e260 do you have?  Turn on the device, and go to Settings > Info.  If you have a firmware version beginning with 01, you have a v1 device.

These machines can alternately be formatted by using Recovery Mode.  In this process, the most important thing to remember is that you DO NOT USE THE WINDOWS FORMAT COMMAND ON THE RESERVED PARTITION!!

You simply place an empty folder named sansa.fmt into the partition named 16MB FORMAT.  The sansa will do an automatic format, and may solve your issue, as opposed to using Windows.

Bob  :wink:

Message Edited by neutron_bob on 10-25-2008 12:44 PM

I’ve got a Sansa 260E…V2

I’m at my complete wits end with this thing!  I’ve reformatted, reauthorized, upgraded windows media player(what does that have to do with Rhapsody anyway!?) Now sandisk and rhapsody are saying the other is at fault…and I’ve got an empty MP3 player. firmware is updated as well.

Windows Media Player is necessary to transfer protected media (DRM).

First, you must be sure that your Sansa is communicating in MTP mode.  Windows XP SP2 is needed, plus WiMP 10 or 11.

On the Sansa, go to Settings > Info.  Do you have 03.01.16 showing?

Then go to Settings > USB Mode > MTP.

Open a windows Explorer window next, by pressing [windows key] + E, or go to My Computer.  Now go ahead and plug in the Sansa.  Does it show up as a single e200 logo under “other devices”?

If it displays under “Devices With Removable Storage”, as a flash drive with letter assigned, MTP is the issue.

Open the Rhapsody 4 client, and see that the Sansa appears as Sansa e260-Internal Memory.

Right-Click on the Sansa.  Does “Deauthorize” show in the menu?

Let me know what you see in the lower right corner of the main Rhapsody window, when the Sansa is selected.  There should be authorization information in the corner.

If there’s nothing there, Deauthorize the device by selecting it from the menu, then Reauthorize.

Hold the [Ctrl] key + [Shift] while right-clicking on the Sansa, and select “Reset Secure Clock”.

Let me know if files will transfer from the Music Guide at this point.

Bob  :smileyvery-happy:

I like most of you am having the same issues. I can not reformat because I will lose over 1700 songs. I guess we’ll see what Rhapsody says. Any suggestions on what to do with Sansa or Sandisk? I guess I need a new Sansa.

Hey, it’s Rhapsody!  This means you can simply retransfer from your library.  You have the option of caching your music files on your PC as well, making reloads atomic fast versus online.  This option does take up hard drive space, however.

If you’ve tried the options of Deauthorize / Authorize, then Reset Secure Clock, and even a single transfer to trigger a license resync, what do you have to lose in simply formatting the device?  Use the resident (built-in) command on the Fuze: Settings > System Settings > Format > Happy Joy Joy.

If this does not work (reauthorize the device using the Rhapsody 4 client afterwards), contact Support at 1-866-SANDISK for further assistance,  as the wmdrm secure clock may have a hardware issue.

Bob  :smileyvery-happy:

Trying this now. Thanks.

Good news and bad news. Good news is it worked…the bad is I lost all 1700 songs but have them in my library on Rhapsody so I just need to get busy. Thanks. Reformating from the more (menu) on the Fuze worked. Thanks again Bob.

Cause and Solution to Secure Clock Error 

First thing you need to do is open up your task manager by clicking control alt delete. 

Select the tab “processes.”  In the process tab you will see a list of programs that are currently running, if you locate a file called csrss.exe it could be a trojan virus that is blocking your subscription music from communicating with your computer properly.  It also effects a lot other things including hardware, personal information, security, etc.  but for this post we will keep it specificly on the secure clock error.  This csrss.exe trojan/virus causes your computer’s internal system to not function correctly including the secure clock.   

NOW WAIT! There are two different csrss.exe files, a good one and a bad/trojan one.  All windows computers have a csrss.exe file on them and this “good” csrss.exe file is need in order for your computer to run propertly so don’t do anything with it until you determine if you have the “good” one or the “bad” one. 

You must first determine whether the csrss.exe file that is running on your computer is the “good” one that ships with the computer (inside your systems32 folder) or whether you have the trojan/virus csrss.exe file infecting your computer and secure clock. 

Since the systems32 program and the Trojan/virus are both name csrss.exe you must run a quick test to see if you have the bad one or the good one or both.

First locate all fo the csrss.exe files inside your “processes” tab inside task manager (you may have more then one).  The way to tell if you have the trojan or “bad” csrss.exe is by right clicking on it and selecting “end task.”  If you have the “good” one then you should get a windows pop up message.  If you you get the windows pop up message, do NOT “end” the task, just ex out or cancel out of it.  You do not want to end the “good” csrss.exe file because it is needed in order for your computer to work properly.  If you “end task” on the good csrss.exe file then your computer will instantly crash (since it is needed to run). 

If when you right click on the csrss.exe file and select “end task” you do NOT get a windows pop up then you may very likely have the csrss.exe trojan virus.  In addition to the right click test you may want to simply look at where this file is located.  If it is in your systems folder it is the good one, if it is anywhere else it is propably the bad one. 

The trojan/virsu version of this csrss.exe file interferes with many of the communication hardware,drivers, software, security, etc., including rhapsody and will prompt this secure clock error message. 

The only way to remove this csrss.exe trojan is to perform a system recovery on your computer returning your computer back to the original manufacturers settings.  There is no way to clean, delete or remove this file trojan, you must perform a complete clean of your system by doing a system recover.

If you cannont determine whether your csrss.exe file are good one or bad ones simply back up your files and software and do a system recovery anyway, your rhapsody and mp3 player will then work fine.

Bob, I took your advise on all steps but when I got to the “license” step, I get this error still…“A problem has occurred in obtaining the secure clock from the server.” 

I have spent 3 hours over the phone with Rhapsody to no avail and even spent an hour on the phone with Sansa for over an hour…

I have uninstalled and re-installed Rhapsody on my computer to no avail…

Having purchased 3 Sansa Fuze’s over the last year all seemed to go well until the Kapersky Anti-virus software was loaded a couple of months ago.  It has since be uninstalled…Still, no change.

I don’t want to have to take all three units back to Best Buy because they will say it is a “computer” problem and expect me to bring it in for service too.

Any help you can provide will be much appreciated!!!


I discovered that there are to csrss.exe files in my “processes” tab in the Task Manager, both are in the “system” directory and the windows pop-up comes up for both of them…one question though, why would one be 664K and the other be 1,092K?  Thank you, Bernie