Who rated this post

Newbie
Posts: 1
Registered: ‎09-26-2013
Re: 32GB Sandisk Micro SD suddenly stopped being recognized by Galaxy S3 phone
[ Edited ]

I bought the 16GB Galaxy Note II International Version when it first came out. Bought a 64GB SD card the same day for it. Been using them with no problems ever since. But the past few weeks my phone has been freezing and forcing me to take out the battery. It continued to happen more frequently until for the past few days it would happen at least a few times an hour. Even though I had factory reset it multiple times.

Anyways, I was at the gym today getting ready to dumbell press, I was listening to music through my apple earpods and my phone, which was in my pocket. I leaned back onto the bench and my phone slipped out of my pocket and the headphone jack came out of the phone's socket. When I put it back in, I couldn't play any music, then I noticed that it said that there's a blank card inside. I tried "turning it off and on" and removing and reinserting the SD card but to no avail. Now it's 12AM, I factory resetted my phone again and the SD card is STILL not working.

I would format it if I didn't have my bodybuilding progress photos of myself from last week on it, I just can't have them gone forever, as I've been taking accurate weekly photos for over half a year now nonstop and can't miss a single week.

I'm hoping for a miracle to happen and for it to fix itself.

I can be contacted at max@grand-direct.com

 

If you're reading this and you have the same problem, then register and post about it. Don't just keep quiet. The more people talk about this, the more likely someone will find a solution.

Who rated this post