Who rated this post

Posts: 2
Registered: ‎03-10-2013
[ Edited ]

TL;DR - skip to the last line.


How stupid of me. I bought two SanDisk Mobile Ultra 64GB USH-I cards. I find SanDisk to be a very reputable brand - I haven't had any problems before with USB flash drives and other MicroSD cards. In fact, I've only ever used SanDisk MicroSDs. I have a 64MB (yes, megabytes), two 2GB, a 4GB, 8GB, 16GB and a 32GB MicroSD card, all of which perform very reliably.


This streak was broken when I intended to purchase one for my phone and one for my tablet.


Initially all was fine with the cards; they both mounted properly, were formatted using exFAT by default and showed a 59.46GB capacity. Misleadingly enough, SanDisk's 64GB "Mobile Ultra" MicroSDs don't actually work on any Android device. They only work on a select few, namely those with unlicensed exFAT support such as the Samsung Galaxy S3, Note 2, Note 10.1 and various others. Knowing exFAT doesn't work on either of my mobile devices, I then proceeded to format one of my cards to FAT32 so it would actually mount in my devices. 


The first card died immediately when I inserted it into my Samsung Galaxy S2. My phone would say "Preparing SD Card...", then it would disappear very soon after. The card still showed up on my computer, so I tried to format again. Windows said that it was unable to complete the format. The card disconnects itself whenever I try to format it or copy files onto it. I have tried multiple readers, multiple computers and multiple OSes, all of them yielded the same "Automatic Unmount Syndrome". So, I sent this one for replacement.


The second card I didn't risk formatting to FAT32. To my surprise, my second device, the ASUS Eee Pad Slider, could mount and read the 64GB exFAT card. I then copied about 30GB of data to it, all seems well. The card didn't disconnect itself, so I tried to copy more data onto it.


But the second time I connected it to my computer, it suddenly switched to read-only mode. I couldn't rename, delete, move or copy any files on the card. So I had no choice but to format it again, but this time to NTFS. I could copy data to it, but it wasn't detected by my ASUS Slider. This is unexpected, because the Slider can mount 2.5" portable external hard drives formatted to NTFS. So I format it to FAT32, and copy the data once again. Luckily for me, the card didn't disconnect itself. My luck soon ran out when the card wasn't detected by my Slider (again), but this time it was much worse than my two previous attempts.


I formatted the card to its default filesystem exFAT, but this time when I started copying my data, it disconnected itself in the same way my first card did. Formatting it will show the error "Windows was unable to complete the format". No third party formatting software could format it. That's the end of the road for both cards.


So from personal experience:


The SanDisk Mobile Ultra 64GB UHS-I MicroSD cards have a 100% failure rate within the first 5 file operations. Do not buy.

Who rated this post