Reply
Newbie
Posts: 1
Registered: ‎03-11-2010

e260/Firmware--Load main image failed?

I have a sansa e260 mp3 player. I was trying to delete some music files, but the some files wouldn't delete. I set it in recovery mode and downloaded firmware (from a link in one of the stickied threads in this forum), extracted the zip and placed the mi4 file into the 16MB folder that popped up when I connected my mp3 player.

 

I disconnected the device, and on the screen, it showed that it read and wrote the main image. However, when it restarts, the screen reads

"Load main image failed

Switch to Recovery mode"

 

I've searched for a while and still can't find a solution. Help would be appreciated!

Newbie
Posts: 14
Registered: ‎03-10-2010

Re: e260/Firmware--Load main image failed?

I have the same problem.... seems like the people at Sansa don't know of a fix yet, but they won't tell us that.
SanDisk Guru
Posts: 5,822
Registered: ‎12-26-2007

Re: e260/Firmware--Load main image failed?

[ Edited ]

I see two potential issues here, so I'd better elaborate.

 

First, there are two versions of the original e200, ones that will yield the error message "load main image failed", the e200R which is the firmware version in this forum page, and the basic e200.  Be sure that, when all was working well, you had a double splash screen, first the SanDisk icon, then the Rhapsody icon, when booting up.  If it was "double", the 1.0.2.165 firmware is the correct one for you.

 

When in Recovery Mode, you will need to transfer the mi4 file, plus the rom file in the download library.

 

There's also another trick, formatting the device and creating a "clean slate" to begin reloading everything.  A strong word of caution when doing this:  Never format the device using the Windows Format command, while the device is in recovery mode.  This will erase required data from the Sansa. 

 

When you format, this will erase all existing media (music, videos, and photos) from the device, so remember to keep backup copies of your music on the computer.  All you need to do is right-click when in the reserved partition, IGNORING the "dangerous" format command that will be available, and select New Folder instead.  Rename this FOLDER sansa.fmt and you're done.  Cool trick, huh?  The presence of this named folder tellsthe Sansa to format automatically.

 

Regarding Recovery Mode:  it's not uncommon for the device to need the procedure more than once if there's a glitch in the process.  Most often, the second firmware transfer does the trick.

 

If the firmware does not transfer, be sure that the two files are unzipped before loading.  To test this, right click on one of the files and select Properties to see if the file is "compressed".  Hey, simple mistakes happen, and it's part of what makes life interesting.  Simply unzip the filkes and try again.

 

Bob  Smiley Very Happy

Message Edited by neutron_bob on 04-11-2010 11:09 AM
Newbie
Posts: 2
Registered: ‎04-08-2011

Re: e260/Firmware--Load main image failed?

neutron_bob, or any other Guru...

 

After years of happily using a Sansa E260, I make the mistake last night of installing Sansa Updater and then, because it said I needed to, allowing it to do an firmware update.  Immediately I received this "Load main image failed" error and I have tried all the instructions you gave with no success.

I'm a little confused about my player - it says E260, but it does have Rhapsody features.  It did have the double spash screen, but does not have a "r" designation after the E260 model name.

So, where do I find this 1.0.2.165 firmware?  The versions I am finding on the SanDisk firmware websites do not have numbers that match that.

Please, please help me out!

 

Thanks.

SanDisk Guru
Posts: 16,315
Registered: ‎04-17-2008

Re: e260/Firmware--Load main image failed?

Right here.

Newbie
Posts: 2
Registered: ‎04-08-2011

Re: e260/Firmware--Load main image failed?

Thank you. I have downloaded those files about a billion times, and they are not working. Finally, in reading through that entire post, noticed that those files are not intended to work in Recovery Mode, which is all this mp3 player will do right now.  Followed the link on unbricking the player from page 11 of that thread, and then another link to a whole list of mi4 firmware files, and finally found the right one that restored my player. All data is lost, but at least the player boots again now.

Just FYI, if anyone else needs to know, the Sansa e260 (without an "R") but with Rhapsody software on it (comes with a "lilmonsta" sticker set) can be restored in recovery mode using the mi4 file found here.

SanDisk Guru
Posts: 16,315
Registered: ‎04-17-2008

Re: e260/Firmware--Load main image failed?

Now that you have got it working again with the original firmware (1.0.2.31), you can safely and easily update to the latest version I linked to above. :smileyhappy:

Newbie
Posts: 1
Registered: ‎12-31-2011

Re: e260/Firmware--Load main image failed?

Hi Guys,

Thanks very much for your guide. If anyone else has a fading Sansa Rhapsody e26XX, please am willing to help because lately i had mine which could fade and i had decided to dump it off. But thanks to you guys who are not selfish, i got the help fforum and i can help the world now. Thanks

 

Anyone seeking gance plese reach me on my mail: dickens.chris1@gmail.com