Reply
Newbie
Posts: 3
Registered: ‎01-26-2012

Sansa SanDisk e200R Never Ending Loop

[ Edited ]

When I turn on the player, the SanDisk screen appears, then the Sansa Rhapsody screen appears. It then flickers and restarts again. It doesn't freeze up on any screen. It just repeats the same process over and over. This happens whether the player is plugged into the computer or not. The only way I can get it to stop is if I turn off the player. Please help.

SanDisk Guru
Posts: 16,265
Registered: ‎04-17-2008

Re: Sansa SanDisk e200R Never Ending Loop

First, try a soft reset. While it's on and doing its loopy thing, press and hold the Power/Home button down for 20-30 seconds. It will most likely power off before this time, but continue to hold the button down for the count to allow the reset time to complete.

 

Now see if it will start up normally. If it does great; problem solved. If not, there's a hard reset you can do. This involves removing the 4 small screws from the back plate and lifting out the battery. Leave it out for a few minutes to allow any residual memory to dissipate. Now drop the battery back in, re-install the back plate and screws, cross your fingers and fire 'er up.

 

Post back if neither of these 2 suggestions work. There may be other things you can try.

Highlighted
Newbie
Posts: 3
Registered: ‎01-26-2012

Re: Sansa SanDisk e200R Never Ending Loop

Thank you so much for the reply. I tried the solutions you recommended and unfortunately, that did not solve my problem. It continues to go through the loop when I start up the player. I purchased the player quite a few years ago. I'm thinking it just ran out of juice to operate. Any other suggestions you have will be much appreciated. Thanks again.

SanDisk Guru
Posts: 16,265
Registered: ‎04-17-2008

Re: Sansa SanDisk e200R Never Ending Loop

Have you tried connecting in Recovery Mode and formatting and re-loading the firmware?

Newbie
Posts: 3
Registered: ‎01-26-2012

Re: Sansa SanDisk e200R Never Ending Loop

I was able to go through the Recovery Mode process and format the drive. When I turned on the player again, I received a "Load image failed" message. I added the firmware back into the Recovery Mode. And the looping problem started again. I'm thinking this player might have played its last song. Smiley Sad