Reply
Newbie
Posts: 6
Registered: ‎11-29-2007

Load Main Image Failed, Switch to Recovery Mode

I have a Sansa e200R media player, and it only recently started to give me problems. I've owned it for over 2 years. The first thing I noticed  that was wrong, was when I tried to add more songs to the 1000+ songs already on it, the songs would be shown as transferred on my computer but they wouldn't show up on the player. So, I then deleted a bunch of songs and then re-synced them, only to get a portion of those added. After that, while the player was connected to my comp, I noticed the Music Folder that was supposed to be on the player when I was viewing it on my computer was no longer there. So, I did a search through this forum to look for answers.

 

I've already downloaded the Firmware, and I've already followed the steps that have been posted within this site in order to Recover the media player's system back to it's original factory settings, but none of it has worked.

 

I've since listed the player on eBay, in an As-Is auction, but if I can actually fix this thing myself, I'd like to keep it. I don't know if, maybe, the system is corrupted beyond any recovery attempts, or what's actually wrong with it. I wouldn't mind being able to remove the 8GB hard drive and attempt to install a new one, or maybe a 16GB hard drive.

 

If anybody has 100% accurate knowledge of exactly how to get the system back to it's original factory settings (I wonder if there's a hidden reset button?) I'd greatly appreciate it.

 

- Mike

SanDisk Fanatic
Posts: 313
Registered: ‎07-13-2009

Re: Load Main Image Failed, Switch to Recovery Mode

There are possible suggestion you can try;

 

First, format the device using Recovery Mode, as it's the most basic connection:

Start with the device OFF.

Slide the HOLD switch to the right (orange showing).

Press and hols the REC button down while connecting, until the device pops up in an open Windows Explorer window as a new icon: 16 MB FORMAT.

 

Warning!  DO NOT USE THE WINDOWS FORMAT COMMAND IN THIS RESERVED PARTITION!!

 

Use the folder method: Right-click in the window, and select New Folder. Rename this folder sansa.fmt and drop the folder into the partition.

Slide the hold switch back to the right, and unplug. The Sansa will now automatically format itself.

 

Smiley Wink 

 

 

 

Newbie
Posts: 6
Registered: ‎11-29-2007

Re: Load Main Image Failed, Switch to Recovery Mode

Thanks for the tip, but I've already tried that, and it didn't work. In fact, after I did that and downloaded the firmware, that's when it started showing me the Load main Image failed crap.

 

I just feel as if the player is fully effed at this point. I'm looking to, eventually, buy a new 16GB player at Wal*Mart, or find a decent player on eBay.

SanDisk Fanatic
Posts: 313
Registered: ‎07-13-2009

Re: Load Main Image Failed, Switch to Recovery Mode

You can contact SanDisk Tech support and check you warranty. Smiley Wink
SanDisk Guru
Posts: 16,258
Registered: ‎04-17-2008

Re: Load Main Image Failed, Switch to Recovery Mode

There won't be any warranty from SanDisk on such an old player, but are you sure you've updated with the correct (R) firmware? Here's the link to it. If you tried to install the regular e200v1 or v2 firmware on a Rhapsody machine that would give you the Load Main Image Failed message as that indicates corrupted firmware.

 

At the very least, I would try the sansa.fmt method of formatting (do a search here) and re-installing the 1.0.2.165 firmware again. Never know; maybe it was just having a bad day when you tried it earlier. Smiley Tongue

Newbie
Posts: 1
Registered: ‎10-06-2009

Re: Load Main Image Failed, Switch to Recovery Mode

thanksssssss
Newbie
Posts: 1
Registered: ‎10-10-2009

Re: Load Main Image Failed, Switch to Recovery Mode

Hello,

What if you did use the format comand in that partition.

Just recieved a 8gb rhapsody, no manual or anything.

When I plugged it in it said it had to be formated so I did.

Now it just turns off after a few seconds.

It says    rockbox bootloader ... file not found then turns off.

Any suggestions?

Newbie
Posts: 6
Registered: ‎11-29-2007

Re: Load Main Image Failed, Switch to Recovery Mode

[ Edited ]
I've relisted my player on eBay http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=150379447423&ssPageName=STRK:MESELX:IT if anybody wants to get it for cheap, then fix it, you'll have a good working player. but, as it is, i don't have any use for it since it won't work for me and nothing i do seems to help.
Message Edited by Myky413 on 10-11-2009 12:19 AM
Message Edited by Myky413 on 10-11-2009 12:19 AM
SanDisk Guru
Posts: 16,258
Registered: ‎04-17-2008

Re: Load Main Image Failed, Switch to Recovery Mode


@Myky413 wrote:
I've relisted my player on eBay <link removerd> if anybody wants to get it for cheap, then fix it, you'll have a good working player. but, as it is, i don't have any use for it since it won't work for me and nothing i do seems to help.

 From the Forum Rules & Guidelines:

 

  • No posting of items For Sale or any advertising without prior permission from Administrator.

     

    Please edit your post and remove the link before the Mod or Admin. gives you a rap on the knuckles and does it for you. :smileywink:

  • Newbie
    Posts: 1
    Registered: ‎11-28-2009

    Re: Load Main Image Failed, Switch to Recovery Mode

    I did all this, and was encouraged when the sansa player (e250r) said it was formatting. Yaay! I thought. However, after the format , upgrade finished, restarting system... I still got "Load main image failed, Switch to recovery mode." Any other ideas? This player has been trouble for a while. It started working a couple of months ago after not working for several months. It did have corrupted files...those have finally been removed. Any other help?